0

Setup: remote server running Debian 9 (no GUI).

Normally, I run transmission-cli without any issues. I want to have transmission-cli save to a remote location. The remote location has plenty of available disk space (I just double-checked with df -h).

This is what I do:

[···]$ sshfs my.remote.server.com:/dir/on/remote/server /home/cal-linux/remote -oallow_other
[···]$ chmod 777 /home/cal-linux/remote

Then, I run transmission-cli as follows:

[···]$ transmission-cli -ep -w /home/cal-linux/remote <magnet-link>

It won't work. This is the output (edited to remove timestamps and IDs and replace the torrent name):

[2018-12-15 ··· ] Transmission 2.92 (14714) started
[2018-12-15 ··· ] RPC Server: Adding address to whitelist: 127.0.0.1
[2018-12-15 ··· ] DHT: Generating new id
[2018-12-15 ··· ] Saved "/home/cal-linux/.config/transmission/torrents/the-torrent.xxxx.torrent"
[2018-12-15 ··· ] Port Forwarding (NAT-PMP): initnatpmp succeeded (0)
[2018-12-15 ··· ] Port Forwarding (NAT-PMP): sendpublicaddressrequest succeeded (2)
Progress: 0.0%, dl from 0 of 0 peers (0 kB/s), ul to 0 (0 kB/s) [None]    [2018-12-15 ··· ] Port Forwarding: State changed from "Not forwarded" to "Starting"
Progress: 0.0%, dl from 15 of 15 peers (0 kB/s), ul to 0 (0 kB/s) [N[2018-12-15 ··· ] the-torrent: Starting IPv4 DHT announce (poor, 15 nodes)
[2018-12-15 ··· ] Saved "/home/cal-linux/.config/transmission/torrents/the-torrent.xxxx.torrent"
[2018-12-15 ··· ] the-torrent: Pausing
[2018-12-15 ··· ] Saved "/home/cal-linux/.config/transmission/settings.json"
Progress: 0.0%, dl from 22 of 22 peers (0 kB/s), ul to 0 (0 kB/s) [None]        
[2018-12-15 ··· ] Saved "/home/cal-linux/.config/transmission/resume/the-torrent.resume"
[2018-12-15 ··· ] the-torrent: Magnet Verify
[2018-12-15 ··· ] the-torrent: Queued for verification
[2018-12-15 ··· ] DHT: Not saving nodes, DHT not ready
[2018-12-15 ··· ] Port Forwarding: Stopped
[2018-12-15 ··· ] the-torrent: Removing torrent
[2018-12-15 ··· ] the-torrent: Pausing

I was originally getting the errors:

UDP: Failed to set receive buffer: requested 4194304, got 425984
UDP: Please add the line "net.core.rmem_max = 4194304" to /etc/sysctl.conf

and similar for wmem_max, but I added the suggested lines to /etc/sysctl.conf and rebooted. Now I don't get those errors, but it still won't work (the above output is after making the changes to sysctl.conf).

Any suggestions?

0

It seems that both your transmission and sshfs work well. As is said in your question, you are downloading (or seeding) with a magnet link. This requires DHT to download the torrent from peers. If there is no client let you download the torrent file they have, you will never get the torrent file and start the real download.

  • This is not applicable here --- as long as there are no peers, the transmission client (on my side) stays there, waiting. You can see the line above in my post: Progress: 0.0%, dl from 15 of 15 peers (0 kB/s) ··· , but it gives up and exits after a few seconds. The "experimental" evidence is clear: I donwload to a local filesystem, and it works; I download to an sshfs mount, and it doesn't (it doesn't even create the files being downloaded). Many many many instances, no single exception. – Cal-linux Dec 17 '18 at 13:50
  • Which user do you run the transmission-cli as? And can you create files yourself in that sshfs mount? sshfs has a strange permission control. Only the user who mount that filesystem can access that. Others (including root) can not. By the way, can you modify files in the host with large storage by sftp? – Steven Yang Dec 17 '18 at 17:08
  • Only the user who mount that filesystem can access that --- but one can override that (that's the -oallow_other in the sshfs command). But anyway, I run everything as one and the same user. I just tried cat > /home/cal-linux/remote, typed something and Ctrl-D'ed, and it works. I even just tried, from a separate login shell as a different unprivileged user, and I could create a file on the remote system. – Cal-linux Dec 17 '18 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.