0

The problem is that I found a solution for my .config/openbox/rc.xml, but not for .config/openbox/autostart.sh. Normally, it's just the command with options like in CLI, but man lxterminal doesn't seem to provide them.

Could you briefly tell me the options for the autostart.sh?

  • It is a bash script file. I'm not sure what exactly you mean by "options". Also, have a look at the openbox docs. Given that, you'd have to add a line like yourcommand & to launch it on login. – rudib Dec 15 '18 at 18:41
0

lxterminal doesn't provide any options for maximizing window, so you may want to consider using another terminal application that provide this option, like

xterm -maximized

Or you can add these lines into applications section inside ~/.config/openbox/rc.xml

<application class="lxterminal">
    <maximized>true</maximized>
</application>

but every instance of lxterminal would be maximized by default.

P.S. Another solution is using wmctrl program inside your script, for example:

#!/bin/sh

wmctrl -r :ACTIVE: -b add,maximized_vert,maximized_horz
# your script start here
neofetch    
read
# end of the script
  • Sorry, changing ~/.config/openbox/rc.xml didn't work for me. – Nepumuk Feb 8 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.