1

I have searched on this error and have seen responses about requiretty adn visiblepw. I have verified and set using visudo that

Defaults !requiretty 

is set. I have even commented out

Defaults   !visiblepw 

and tried to set it via

Defaults   visiblepw 

I am able to run a shell script that I developed. It calls a script in this format: su -c "mycommand <params_to_mycommand>" user All this works OK, until it gets called by separate process. I keep getting the message "standard in must be a tty" when not run through a terminal connection. I am stumped as I tried adding the

Defaults:user !requiretty

As stated above, although not secure, tried

Defaults !requiretty
Defaults visiblepw

Running Oracle Enterprise Linux 6.6 I am stumped. What else can I check?

closed as unclear what you're asking by Jeff Schaller, Christopher, Scott, Thomas, Kusalananda Dec 15 '18 at 10:53

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    you mention some options that relate to sudo, but the only command I see in your post calls su. I think you need to show more of your situation in order to get a clear answer. – Jeff Schaller Dec 14 '18 at 20:25
  • Welcome - I'm afraid it's not very clear exactly what is going on for you. Including at least some of the relevant lines of the script that you developed might help. Perhaps also show a case of when it "works OK". – Randall Dec 14 '18 at 20:29

Browse other questions tagged or ask your own question.