0

I have a pretty old version of Samba Server installed on a Linux machine. Which Linux normally doesn't require "WORKGROUP" or "SAMBA" or any domain name to log in. Normal username and password should get the job done.

So I have a CentOS 7.1 installed with Samba version 4.4 and I use smbclient to log in, which worked great.

And now I have a clean installed CentOS 7.6 (1810) with samba version 4.8 installed. The smb.conf is completely identical, but when I need to use smbclient to log in the Samba Server of the Linux machine, it shows:

Enter SAMBA\username's password:

So I entered the same password which I used on CentOS 7.1, and it returns:

tree connect failed: NT_STATUS_WRONG_PASSWORD

So when I use the same smbclient command to connect from CentOS 7.1 with an older Samba version 4.4, it prompts:

Enter username's password:

And then I entered the same password and it lets me in.


There might be 2 ways to solve the problem.

  • Downgrade the Samba version to 4.4. But I don't know how to do it.

    or

  • Disable using "WORKGROUP" or something like that completely. But I don't know how to do it either.

1

You probably already have done this since you were able to login via the older smbclient (on CentOS 7.1), but make sure to set the smb user's password on the new server (CentOS 7.1):

sudo smbpasswd -a username

Otherwise, confirm your smb.conf has entry workgroup = WORKGROUP, etc.

You can test further via:

smbclient -L myhost -U SAMBA/username -W workgroup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.