0

I am trying to overclock the memory on my GPU with AMDGPU Pro 18.40 driver.

Nonetheless, /sys/class/drm/card0/device/pp_od_clk_voltage is an empty file and I cannot write to it.

When I try

echo "m 2 1600 950" > /sys/class/drm/card0/device/pp_od_clk_voltage

as root it produces the following error:

-bash: echo: write error: Invalid argument

I have amdgpu.ppfeaturemask=0xffffffff in GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub.

I have also tried running:

echo manual | sudo tee /sys/class/drm/card0/device/power_dpm_force_performance_level

My question is based on the answer to the following question: Can't overclock GPU using amdgpu driver on archlinux The author claims that this method works, however it obviously does not.

0

I had to install this: https://github.com/BoukeHaarsma23/WattmanGTK

and then I ran it, and it told me the value I needed to pass to amdgpu.ppfeaturemask. In my case on a Vega 64 the value is 0xfffd7fff

And yea you add that to grub :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy