0

When trying to open virtualbox GUI over a forwarded session, I get the following error:

steve@remoteHost:~$ virtualbox
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.

Whilst xeyes works as expected.

How to debug this?

Anyone had similar issues?

Tried some env vars: LIBGL_ALWAYS_INDIRECT without success.

0

The issue seems to have been remenants over a previous Virtualbox install.

Removing the packages, in my case:

$ sudo apt remove virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
$ dpkg -l |grep virtualbox
ii  virtualbox-5.2                       5.2.22-126460~Ubuntu~xenial                  amd64        Oracle VM VirtualBox
rc  virtualbox-guest-utils               5.1.38-dfsg-0ubuntu1.16.04.1                 amd64        x86 virtualization solution - non-X11 guest utilities
rc  virtualbox-guest-x11                 5.1.38-dfsg-0ubuntu1.16.04.1                 amd64        x86 virtualization solution - X11 guest utilities
0

Taking into account the error message you have "Make sure 3D acceleration is enabled for this VM", you have to:

1) Shut down your VM

2) Go on "Settings" section

3) Choose "Display" section then "Video"

4) Tick the box "Enable 3D acceleration" and Ok.

Let me know if it works :) ! Good Luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.