0

From my understanding, when installing Linux on a USB, it's only guaranteed to boot on that machine, unlike the liveUSB installer.

So my Dell laptop already has Linux on it's internal hard drive. When I put the installer in I hit F12 before booting and it will give me an option to boot from that installer.

Then, I choose the target to be on an empty usb. After finish installing. I pops out the installer and try to boot with the new USB. The BIOS won't list it when I hit F12.

I tried to install the boot record on both /dev/sdb and /dev/sdb1, still doesn't seem to work.

What makes those live installers special that the BIOS can see it?

0

There are several possibilities, and without knowing your laptop model and the name and version of the Linux distribution you're installing, it's hard to say for certain.

The most important piece of information would be whether your system uses traditional BIOS-style boot or UEFI.

When booting UEFI-style from a removable media, the media should have a partition with a filesystem that is understood by your system firmware: FAT32 support is guaranteed by the UEFI specification, ISO9660 might also be supported, and perhaps NTFS, but not much else. If a supported filesystem type is found on a removable media, the firmware looks for a boot file in a standard UEFI fallback boot path: \EFI\BOOT\bootx64.efi on 64-bit x86 hardware. The installer might be designed for HDD/SSD-based installations in mind, and it might not set up the bootloader using this fallback path. That might be easily fixed by accessing the freshly-installed stick in another OS, locating the primary UEFI bootloader file, and copying it to the correct location.

If you are booting traditional BIOS-style, the installer has no way of knowing for certain which order your storage devices were detected by the BIOS; furthermore, it has no way of anticipating how that ordering will change when you remove the installer. As a result, the installer will have to rely on unreliable heuristics, and it might be writing the bootloader to the wrong device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.