2

I've create a simple file.desktop from chromium but every time I click on it it prompt :

this file seems a script whatn you want to do?

Execute Execute in terminal Open Cancel

This happen with all files .desktop on the Desktop folder.

this is an example:

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Terminal=false
Type=Application
Name=PROVA
Exec=/usr/bin/chromium --profile-directory=Default --app-id=ffgolldjdihlhdjkieofmjgjikkcbjbj
Icon=chrome-ffgolldjdihlhdjkieofmjgjikkcbjbj-Default
StartupWMClass=crx_ffgolldjdihlhdjkieofmjgjikkcbjbj

How can I set all for Execution without prompt?

2

Open PCManFM, Go to Edit/Preferences/General, Check box for "Don't ask options on launch executable file"

From https://askubuntu.com/questions/333256/how-to-skip-execute-file-dialog-in-lubuntu-pcmanfm

2

The string #!/usr/bin/env xdg-open should not be in a .desktop file.

These files are simple INI files defining how to open an application, not scripts to be executed.

Delete this erroneous line and try again.

1
  • No luck, still getting the same prompt.
    – user340971
    Jul 29 '20 at 8:35
1

To remove the prompt when launching an executable file, do the following: Open File Manager Select Edit - Preferences - General Tick the option "Don't ask options on launch executable file"

0

Another workaround is to put the desktop entry in its default directory and create a link to it, like the OS does when you drag and drop a entry from the menu to desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.