1

So, I'm on a HiDPI machine (XPS 9370) and using the Adwaita cursor; this is on a fresh install of Antergos w/ i3 for context.

I've been playing around with some settings for adapting to HiDPI, but I realized that my cursor changes size depending on what application it is hovering on. Whereas when not hovering over any application or hovering over a few, it may be sized appropriately for the display, but, say when hovering over termite or Firefox, it will decrease to a fraction of the size and become barely visible.

How do I make the cursor size consistent across the entire system?

Xcursor.size does not seem to affect the cursor sizes in the programs I listed.

  • are you loading your .Xresources file with xrdb every time you start i3? what if you add Xcursor.size: xx into your .Xresources file and run xrxb ~/.Xresources during run time? – bgregs Dec 10 '18 at 19:05
  • @bgregs Sorry, I was unclear. Xcursor.size doesn’t affect (GTK?) programs like Firefox and termite. – hyperum Dec 10 '18 at 23:10
  • Yeah, now that I wrote that comment, I’m feeling really dumb. – hyperum Dec 10 '18 at 23:24
1

To have GTK 3 programs have a consistent cursor size with X, set gtk-cursor-theme-size=n for n as in Xcursor.size. The setting can be found in .config/gtk-3.0/settings.ini

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.