2

Upon Boot, Debian doesn't show an internet signal. When I click on it, it shows that wireless is "unavailable". I'm on an HP laptop, so I press F12 to try to enable my Realtek internet adapter. I still don't get a response. The peculiar thing is, upon my first boot I had the same problem, but when I rebooted the system to use internet on my Windows installation, it worked. I booted back into Debian after doing some searching and found that my internet was working! I've since been using my internet on Debian to research the other problem I have. I recently shut down my laptop for transport and when I booted to Debian, internet wasn't working anymore. Is this a driver problem? How do I fix this?

1
  • I am using Debian. I know my username is KALI99, but that was because I had Kali a few months ago. I installed Debian recently because I was recommended by other Linux experts, and because my laptop seems to (for now) run better,
    – KALI99
    Commented Dec 10, 2018 at 5:12

1 Answer 1

5

It works with internet cable?

If so do this:

    echo 'deb http://ftp.debian.org/debian/ stretch main contrib non-free' >/etc/apt/sources.list
    apt-get update
    apt-get install firmware-realtek 

To install the network drivers...

Restart the computer and try again to locate the wifi networks.

If you do not have a way to use the internet via cable, download the package from here: http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-realtek_20161130-4_all.deb

Save in a pendrive, open the pendrive on the debian machine, click with the right button of your mouse in the pendrive "folder", Open in a Terminal, them install it using:

 dpkg -i firmware-realtek_20161130-4_all.deb

Restart the computer and try again to locate the wifi networks.

3
  • I will try this, my internet came back. I got it on by not doing a full shutdown. I instead hit restart in windows and switched to debian.
    – KALI99
    Commented Dec 10, 2018 at 23:06
  • Thank you! As soon as I booted my laptop from a complete shutdown, I noticed that the info on the screen was missing an error line that I had seen since installation. It so happens that line was that a firmware file rtl*****.bin was missing. I'm guessing with what I typed in replaced that missing file. Again, thank you.
    – KALI99
    Commented Dec 10, 2018 at 23:18
  • This missing files are proprietary (non-free), so they cannot be distributed on debian by default. The repository in sources.list must be with the "non-free" option enabled so then you can install this packages... and that is why this solved your problems. Commented Dec 17, 2018 at 10:48

Not the answer you're looking for? Browse other questions tagged .