0

As I have mentioned here for some reason whenever I try to use CTRL key for any of the keyboard shortcuts, it prints the caret sign ^. Here is my .bashrc file:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi


# export TERM=”screen-256color” 


if [ -f `which powerline-daemon` ]; then
  powerline-daemon -q
  POWERLINE_BASH_CONTINUATION=1
  POWERLINE_BASH_SELECT=1
  . /usr/local/lib/python3.6/dist-packages/powerline/bindings/bash/powerline.sh
fi

And when I run stty -a I get:

speed 9600 baud; rows 55; columns 204; line = 0; intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = M-^?; eol2 = M-^?; swtch = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; discard = ^O; min = 1; time = 0; -parenb -parodd -cmspar cs8 -hupcl -cstopb cread -clocal -crtscts -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc ixany imaxbel iutf8 opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0 isig icanon iexten echo echoe -echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke -flusho -extproc

I need to diagnose why this has happened and how I can resolve it.

closed as off-topic by jasonwryan, l0b0, G-Man, JigglyNaga, Isaac Dec 10 '18 at 12:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question has been posted on multiple sites. Cross-posting is strongly discouraged; see the help center and community FAQ for more information." – jasonwryan, G-Man, JigglyNaga

  • 2
    Make a copy of your .bashrc and eliminate lines until it works as expected. Which line is responsible for this change in the behaviour? – l0b0 Dec 9 '18 at 21:57
  • ok, that would be a bit cumbersome. I was hoping I could receive a more straightforward approach. – Foad Dec 9 '18 at 21:58
  • 1
    You failed to say that this problem appear when you ssh from a Mac to a Ubuntu system. Have you tried a reboot (of both computers) already ? – Isaac Dec 10 '18 at 12:56
  • 1
    @Foad For Both computers?. That seems odd. That a ctrl-c prints a ^C is not so odd, it is a very old way to encode control characters by shifting the seventh bit. So ctrl-a (001) is ^A, ctrl-b (002) is ^B, etc. Is a ctrl-c still working? To test: execute sleep 20 and press Ctrl-C to find out if it stops. If it does, the chracters are working, if not, the console is not receiving the characters (I suspect it is). – Isaac Dec 11 '18 at 10:12
  • 1
    Then, if the console receives the characters, what do you see if you execute cat -A and type some control characters like Ctrl-A, Ctl-b, Alt-tab, the arrows, etc. If the X server is correctly capturing the shortcuts, the Alt-tab should not be received by your console application, if it is, there is a problem with X shortcuts. Please test and report back. @Foad – Isaac Dec 11 '18 at 10:12
1

I would look at the following:

xmodmap -pke

Like on my system the control keys are:

  • This will list the current mapping of your keys. If you find the offending setting you can reassign that key.

    keycode  37 = Control_L NoSymbol Control_L
    keycode 105 = Control_R NoSymbol Control_R
    

Use xev to find out what the keystream is, then remap it back to control.

  • My xev shows this for control:

    KeyRelease event, serial 37, synthetic NO, window 0x3000001,
    root 0x15c, subw 0x0, time 5417642, (167,-18), root:(195,67),
    state 0x14, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
    

Something like:

xmodmap -e "keycode 37 = Control_R NoSymbol Control_R"

Would make my control key function normally.

To make this permanent edit your xorg configuration file to reflect the new mapping.

Not the answer you're looking for? Browse other questions tagged or ask your own question.