0

I am trying to install some software in an old version of Linux (the updated software for 18.04 is unstable, the older version seems to be better). However, the code I used way back to install the packages for 18.04 is not working for ubuntu 14.04.

The code I'm am using is copied below

 packages="libklustersshared_2.0.0 klusters_2.0.0 neuroscope_2.0.0 ndmanager_2.0.0"
 psuffix="-trusty_amd64.deb"

 for package in $packages;
 do
    wget http://sourceforge.net/projects/neurosuite/files/ubuntu/${package}${psuffix}/download -O /tmp/${package}${psuffix}
    apt -y install /tmp/${package}${psuffix}
    rm /tmp/${package}${psuffix}
 done

In 18.04 this executes fine. In 14.04 I get the resulting error

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package /tmp

I have confirmed that the downloads do exist and the paths are accurate. I suspect I am missing some dependency, because when I run this code downloading and installing the 14.04 software in 18.04 Ubuntu it proceeds past this point until a later fault (which is why we are using 14.04 in the first place). I'm not really sure what could be going wrong.

  • Where did $packages come from, and what's in it? psuffix is also empty. – Michael Homer Dec 9 '18 at 0:21
  • @MichaelHomer My apologies, I didn't want to clog up the question. I have added the previous code where those variables are defined – Pablo Dec 9 '18 at 0:27
  • 3
    I think the version of apt in trusty (1.0.1?) may be too old to support the installation of local .deb files (which appeared in 1.1~exp1 iirc)? You should be able to use gdebi instead (or perhaps dpkg -i followed by apt-get -f install to resolve dependencies) – steeldriver Dec 9 '18 at 0:46
  • @steeldriver Thanks for your advice. I tried installing with gdebi. This installs the first package (libklustersshared) without an error, but fails on the second package (klusters), with the following error - This package is uninstallable Dependency is not satisfiable: libklustersshared. I know the libklustersshared must be installed first - I am therefore speculating that there was an error with the gdebi installation. It outputs (before moving to the klusters package) 'Requires the installation of the following packages'. Is there an extra command I need to enter for these packages? – Pablo Dec 9 '18 at 18:08
  • @steeldriver A further update: using apt-get -f install is progress, but lots of packages are not installing properly, so I assume I will have to manually find these dependencies are install those. – Pablo Dec 9 '18 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.