0

My operating system is Debian 9.1 with Cinnamon 3.2.7. I installed Audacious (version 3.7.2) from the Package Manager and want to update to the latest released. Per these instructions, I attempted to update by entering the following commands:

sudo add-apt-repository ppa:nilarimogard/webupd8   
sudo apt update   
sudo apt install audacious

After a prompt to press Enter, I received the following output:

gpg: keybox '/tmp/tmpseyl6p36/pubring.gpg' created  
gpg: /tmp/tmpseyl6p36/trustdb.gpg: trustdb created  
gpg: key 531EE72F4C9D234C: public key "Launchpad webupd8" imported  
gpg: no ultimately trusted keys found  
gpg: Total number processed: 1  
gpg:               imported: 1  
gpg: no valid OpenPGP data found.  
Exception in thread Thread-1:  
Traceback (most recent call last):  
  File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner  
    self.run()  
  File "/usr/lib/python3.5/threading.py", line 862, in run  
    self._target(*self._args, **self._kwargs)  
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 688, in addkey_func  
    func(**kwargs)  
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 386, in add_key  
    return apsk.add_ppa_signing_key()  
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 273, in add_ppa_signing_key  
    cleanup(tmp_keyring_dir)  
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 234, in cleanup  
    shutil.rmtree(tmp_keyring_dir)  
  File "/usr/lib/python3.5/shutil.py", line 480, in rmtree  
    _rmtree_safe_fd(fd, path, onerror)  
  File "/usr/lib/python3.5/shutil.py", line 438, in _rmtree_safe_fd  
    onerror(os.unlink, fullname, sys.exc_info())  
  File "/usr/lib/python3.5/shutil.py", line 436, in _rmtree_safe_fd  
    os.unlink(name, dir_fd=topfd)  
FileNotFoundError: [Errno 2] No such file or directory: 'S.gpg-agent.browser'  

Then, when I attempted to run the update step (sudo apt-get install --only-upgrade audacious), I received more errors:

Ign:1 http://deb.debian.org/debian stretch InRelease  
Ign:2 http://www.scootersoftware.com bcompare4 InRelease                         
Ign:3 http://ftp.us.debian.org/debian stretch InRelease                          
Hit:4 http://deb.debian.org/debian stretch Release                               
Hit:5 http://www.scootersoftware.com bcompare4 Release                           
Hit:6 http://ftp.us.debian.org/debian stretch-updates InRelease                  
Hit:7 http://security.debian.org/debian-security stretch/updates InRelease       
Hit:8 http://ftp.us.debian.org/debian stretch Release                            
Ign:11 http://ppa.launchpad.net/alexanderk23/ppa/ubuntu artful InRelease         
Ign:13 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu disco InRelease     
Err:14 http://ppa.launchpad.net/alexanderk23/ppa/ubuntu artful Release  
  404  Not Found  
Err:15 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu disco Release  
  404  Not Found  
Reading package lists... Done  
E: The repository 'http://ppa.launchpad.net/alexanderk23/ppa/ubuntu artful Release' does not have a Release file.  
N: Updating from such a repository can't be done securely, and is therefore disabled by default.  
N: See apt-secure(8) manpage for repository creation and user configuration details.  
E: The repository 'http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu disco Release' does not have a Release file.  
N: Updating from such a repository can't be done securely, and is therefore disabled by default.  
N: See apt-secure(8) manpage for repository creation and user configuration details.

Finally, when I ran the install step (sudo apt install audacious), it said the latest was already installed. It must not have accepted the PPA.

Reading package lists... Done  
Building dependency tree         
Reading state information... Done  
audacious is already the newest version (3.7.2-1+b1).  
0 upgraded, 0 newly installed, 0 to remove and 241 not upgraded.  

After browsing online, I entered the following commands to undo my changes:

sudo add-apt-repository --remove ppa:nilarimogard/webupd8  
sudo apt update  
sudo apt-key del 531EE72F4C9D234C  
sudo apt update  

What additional commands do I need to run in order to get the PPA to add properly?

  • 1
    That PPA is for Ubuntu and Mint. Mixing repos from different distros is going to lead to all sorts of problems as you have found out. You could however install it from source or accept that when you use Debian you will be using older versions of software. – kemotep Dec 8 '18 at 20:40
  • Thank you for the information, kemotep. Is it relatively straightforward to install programs from the source? I work as a software engineer, so I am probably capable of doing it, but I have not installed programs from source on Linux. – Daniel Charles Dec 8 '18 at 20:48
  • Installing from source can be non trivial as the software in question can depend on various libraries or other components that Debian does not have or does not have the right version of. Here is more information on installing Audacious. I would recommend you keep it to a minimum what you install from source and try to manage everything with apt. – kemotep Dec 8 '18 at 21:01
  • They admit in that link that their instructions for installing from source are not very useful. I gave it a try anyway, but I already ran into a problem with a dependency. That's too bad. I may try a little longer, but failing that, looks like I'm looking at either installing a different Linux distro or finding a new music player application. – Daniel Charles Dec 8 '18 at 21:10
1

This doesn’t answer your question as stated, but it will give you a packaged version of Audacious 3.10 on Debian 9. Here’s how to rebuild the current Buster package on Debian 9:

  • enable Stretch backports, which we’ll need

    echo deb http://deb.debian.org/debian stretch-backports main | sudo tee /etc/apt/sources.list.d/stretch-backports.list
    sudo apt update
    
  • install some useful tools we’ll need

    sudo apt install devscripts
    
  • switch to a temporary directory

    cd /tmp
    
  • download the source packages

    dget -xu http://deb.debian.org/debian/pool/main/a/audacious/audacious_3.10-1.dsc
    dget -xu http://deb.debian.org/debian/pool/main/a/audacious-plugins/audacious-plugins_3.10-1.dsc
    
  • start building Audacious

    cd audacious-3.10
    
  • build a meta-package with the build-dependencies (this will allow us to clean up later)

    mk-build-deps debian/control
    
  • install it then move it out of the way

    sudo apt install ./audacious-build-deps_3.10-1_all.deb
    mv audacious-build-deps_3.10-1_all.deb ..
    
  • now build Audacious

    dpkg-buildpackage -us -uc
    
  • install packages we’ll need to build the Audacious plugins (we can’t install Audacious on its own without those)

    cd ..
    sudo dpkg -i audacious-dev_3.10-1_amd64.deb libaudcore5_3.10-1_amd64.deb libaudgui5_3.10-1_amd64.deb libaudtag3_3.10-1_amd64.deb
    
  • same process to build the plugins (with an upgrade of debhelper to the Stretch backports version, required here)

    cd audacious-plugins-3.10
    mk-build-deps debian/control
    sudo apt install -t stretch-backports debhelper
    sudo apt install ./audacious-plugins-build-deps_3.10-1_amd64.deb
    mv audacious-plugins-build-deps_3.10-1_amd64.deb ..
    dpkg-buildpackage -us -uc
    

The build is complicated by the inter-dependencies between Audacious and its plugins, which is why you need to build Audacious first, the install its libraries and development package, then build the plugins. Once all that’s done you can install Audacious itself using the resulting package:

cd ..
sudo dpkg -i audacious_3.10-1_amd64.deb audacious-plugins_3.10-1_amd64.deb audacious-plugins-data_3.10-1_all.deb

To clean up the packages using during the build:

sudo apt purge audacious-dev build-essential debhelper devscripts gcc gcc-6 audacious-build-deps audacious-plugins-build-deps
sudo apt --purge autoremove
  • Also, I forgot to go into /tmp, so I was running from /home/daniel. Not sure if that could be a problem. I can post the full output upon request; there's a lot. – Daniel Charles Dec 9 '18 at 15:56
  • This time, when I run sudo apt install ./audacious-plugins-build-deps_3.10-1_amd64.deb, I get the following: (see next comment due to length restrictions) – Daniel Charles Dec 9 '18 at 17:44
  • Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: audacious-plugins-build-deps : Depends: debhelper (>= 11) but 10.2.5 is to be installed E: Unable to correct problems, you have held broken packages. – Daniel Charles Dec 9 '18 at 17:45
  • 1
    No, it’s just me not checking the dependencies properly (I did run all this, but my system already had various other pieces set up), you need Stretch backports too, see my update. – Stephen Kitt Dec 9 '18 at 19:32
  • 1
    OK, we only need to install debhelper from backports so I’ve separated that out. (Restart from cd audacious-plugins-3.10 above.) This time I checked everything in a new Debian 9 VM so I’m reasonably confident it will work! – Stephen Kitt Dec 10 '18 at 10:47
2

Don't use Ubuntu PPAs in Debian.

Don't make a FrankenDebian Debian Stable should not be combined with other releases. If you're trying to install software that isn't available in the current Debian Stable release, it's not a good idea to add repositories for other Debian releases. The problems might not happen right away, but the next time you install updates.

The reason things can break is because the software packaged for one Debian release is built to be compatible with the rest of the software for that release. For example, installing packages from buster on a stretch system could also install newer versions of core libraries including libc6. This results in a system that is not testing or stable but a broken mix of the two.

Repositories that can create a FrankenDebian if used with Debian Stable:

Debian testing release (currently buster)

Debian unstable release (also known as sid)

Ubuntu, Mint or other derivative repositories are not compatible with Debian!

Ubuntu PPAs

Source https://wiki.debian.org/DontBreakDebian

What was wrong with Audacious from Debian Repositories? https://packages.debian.org/search?keywords=audacious

  • When I installed Audacious from the Synaptic Package Manager, the version installed is 3.7.2, which is not the latest. The latest released by the developers is 3.10. Even if I can't get the absolute latest, I would at least like version 3.9, which has some fixes that I would like. Is there I way I can get a newer version than what's in Synaptic Package Manager? – Daniel Charles Dec 8 '18 at 20:46
  • 1
    Backport from Buster? backports.debian.org/Instructions – user8779 Dec 8 '18 at 20:53
  • Looks like there may not be a backport for Audacious for my OS. From your link above, there is a jessie-backport, but not a stretch-backport. I entered the commands from the link you just posted (i.e., added line to sources.list, then apt-get -t stretch-backports install "audacious"), but it still says I already have the latest. – Daniel Charles Dec 8 '18 at 21:07
  • @DanielCharles you need to use stretch backports. It is just stretch-backports you are not using jessie. A lot of Debian information is "out of date" in the sense that the names are wrong but the task is the same. – kemotep Dec 8 '18 at 21:12
  • I did not use jessie. I added deb http://ftp.debian.org/debian stretch-backports main to /etc/sources.list and then entered apt-get -t stretch-backports install "audacious". Was this incorrect? The only reason I mentioned jessie it is that arochester's original link (packages.debian.org/search?keywords=audacious) only contains results for jessie-backport; there are no stretch-backports listed. – Daniel Charles Dec 8 '18 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.