I am trying to compile the 4.19 kernel on my Linux Mint machine. I copied my current config (which is from 4.15), opened make menuconfig in order to append a local version string, saved it and then tried make. However I get this error:

scripts/kconfig/conf  --syncconfig Kconfig

*** Error during sync of the configuration.

scripts/kconfig/Makefile:69: recipe for target 'syncconfig' failed
make[2]: *** [syncconfig] Error 1
Makefile:539: recipe for target 'syncconfig' failed
make[1]: *** [syncconfig] Error 2
Makefile:635: recipe for target 'include/config/auto.conf' failed
make: *** [include/config/auto.conf] Error 2

I also tried not using make menuconfig but when I type make I get a bunch of questions about some options I don't have a clue what they are for (I guess those are the same as with make config).
Another thing I tried was using make defconfig which stated Default configuration is based on 'x86_64_defconfig'. However when executing make afterwards I get the exact same error.

I have the feeling that there are some sort of errors being introduced in the config or that I am missing something that is needed for compiling the kernel source. However I have no idea where I can get more information about those Error 1 and Error 2.
Does somebody has an idea what could be wrong? If needed I'll upload my .config-file so that you can have a look at it.

EDIT: I also tried it with the 4.18 kernel version but this time I didn't even touch the config that comes with it from git. Still I get the very same error. I suspect that there is something wrong on my machine (some missing dependencies or something like that). However - as stated above - I do not know where I should start searching as the error message that unspecific...

I have installed a new distribution (from Linux Mint to KDE Neon) but I am still getting the very same error. I start suspecting that this might actually be a bug in the kernel somehow...

  • 1
    I added an answer to this question here: stackoverflow.com/a/61169878/1487069
    – Carlo Wood
    Apr 12, 2020 at 10:29
  • Thank you for the hint! :)
    – Raven
    Apr 12, 2020 at 11:44
  • 1
    @CarloWood, if you already posted an answer to this question there, please consider posting it here as an answer too to complete this Q&A. Oct 10, 2021 at 5:49
  • 1
    @Raven, if you learned a solution to your problem, please consider posting it as an answer to your question below. Oct 10, 2021 at 5:51
  • 1
    @RomanRiabenko I would if I had an answer. I ended up not compiling kernels myself anymore and thus did not keep poking around for possible solutions
    – Raven
    Oct 10, 2021 at 13:15


You must log in to answer this question.

Browse other questions tagged .