0

I have been trying to follow the instrucitons here: https://nixos.wiki/wiki/Using_JACK_with_PulseAudio

error: attribute 'pulseaudio' missing, at /etc/nixos/configuration.nix:17:33
(use '--show-trace' to show detailed location information)

I receive the above when trying

  hardware.pulseaudio.package = pkgs.pulseaudio.override { jackaudioSupport = true; };

I've also found this github commit - but I don't think it's in the nixos channel yet? https://github.com/NixOS/nixpkgs/blob/f4811789605ee3fb1c069fd6c569aae32cd27d1e/pkgs/misc/jackaudio/default.nix

1

It looks like pulseaudio is not installed, I would do the following.

Add to your configuration:

hardware.pulseaudio.enable = true;
hardware.pulseaudio.support32Bit = true;    ## If compatibility with 32-bit  
    applications is desired.

You may need to add users to the audio group for them to be able to use audio devices:

users.extraUsers.alice.extraGroups = [ "audio" ... ];

More info: Here

0

I think I had to update the channels,

I've added myself to the "audio" groups as mentioned by @Michael.

Add this to my config:

let 
  hardware.pulseaudio.package = pkgs.pulseaudio.override { jackaudioSupport = true; };
in
{
...

I had stop pulseaudio systemctl --user stop pulseaudio and then kill the process pkill pulseaudio.

I had to install these packages:

 unstable.jack2
 libjack2
 qjackctl

Add this file:

cat ~/.config/pulse/client.conf
daemon-binary=/var/run/current-system/sw/bin/pulseaudio

And then using qjackctl set the jackd path to jackdbus and enable the two settings (Setup > Misc) for Enable D-Bus interface and Enable JACK D-Bus interface.

Not sure if all the above is required and optimal - but it works on initial inspection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.