I'm starting Xorg on a headless server while trying to take advantage of the Intel iGPU.

my .xinitrc:

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

xrandr -d :0 --output VIRTUAL1 --primary --auto
xrandr --newmode "1920x1080_60.00" 173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode VIRTUAL1 "1920x1080_60.00"

exec cinnamon-session

started via SSH with DISPLAY=:0 startx -- vt7.

I have verified the Intel iGPU is being used via intel_gpu_top and xrandr looks like this:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080_60.00  59.96* 
VIRTUAL2 disconnected (normal left inverted right x axis y axis)

TigerVNC is then started as DISPLAY=:0 x0vncserver -rfbauth .vnc/passwd.

TigerVNC log:

Thu Dec  6 01:42:59 2018
 Geometry:    Desktop geometry is set to 1920x1080+0+0
 XDesktop:    Using evdev codemap

 XDesktop:    XTest extension present - version 2.2
 XDesktop:    RANDR extension not present
 XDesktop:    Will not be able to handle session resize
 Main:        Listening on port 5900

Thu Dec  6 01:43:01 2018
 Connections: accepted: 192.168.16.3::49657
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)

Thu Dec  6 01:43:04 2018
 XDesktop:    Enabling 8 buttons of X pointer device
 XDesktop:    Allocated shared memory image
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888                                                                      
 VNCSConnST:  Client pixel format depth 24 (32bpp) little-endian rgb888

I've also tried x11vnc with identical results.

My problem: I'm getting roughly 0.5 FPS update rate (i.e. an update every ~2 seconds), making working with this extremely tedious. CPU usage is quite low on server and client machine, the network connection is direct crossover 10 Gbit/s.

I initially suspected a wrong/low refresh rate as no display is connected, so I set up the virtual display with a 60 Hz refresh rate.

On the client side there is a Windows 10 machine where I've tried RealVNC Viewer and TightVNC Viewer, both with identical results. Changing quality levels has no effect either.

How do I fix my VNC session and make it fast?

put on hold as too broad by Rui F Ribeiro, RalfFriedl, msp9011, Archemar, DarkHeart Dec 10 at 0:36

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

I use Remmina, set the color depth to High color 16 bpp, Quality to Medium. Using compression on the ssh side hurts things unless the connection is long distance or lossy to start with, so don't unless you have too. Set the ssh tunnel up within Remmina as well. This should be snappy, my setup is roughly the same as yours, and it is more than responsive enough.

https://remmina.org/remmina-on-windows/

https://blogs.msdn.microsoft.com/wsl/2016/04/22/windows-subsystem-for-linux-overview/

As a final note, there is always VirtualBox.

  • Ah sorry, I should have clarified the client side is Windows. – Cobra_Fast Dec 6 at 1:20
  • Should work though, give it a shot, let me know how it works out... – Michael Prokopec Dec 6 at 1:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.