2

I have a problem running the ownCloud client on Linux Mint 19 Tara. It doesn’t start. If run from the command line, it gives me these errors:

pavel@lenovo ~ $ owncloud
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by owncloud)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5DBus.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Xml.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/ownCloud/lib/x86_64-linux-gnu/libowncloudsync.so.0)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/ownCloud/lib/x86_64-linux-gnu/libowncloud_csync.so.0)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libqt5keychain.so.1)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Widgets.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5WebKit.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Network.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Gui.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5)
owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Sql.so.5)

The most of the ocqt libraries get found but they refer to the system libQt5Core library. How’s that possible when the /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Core.so.5 file exists and is a symbolic link to libQt5Core.so.5.10.1?

Tried to prepend LD_LIBRARY_PATH=/opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu but the result was the same.

Tried with ldd:

pavel@lenovo ~ $ LD_LIBRARY_PATH=/opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu ldd `which owncloud`
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /usr/bin/owncloud)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5DBus.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Xml.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/ownCloud/lib/x86_64-linux-gnu/libowncloudsync.so.0)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/ownCloud/lib/x86_64-linux-gnu/libowncloud_csync.so.0)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libqt5keychain.so.1)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Widgets.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5WebKit.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Network.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Gui.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5)
/usr/bin/owncloud: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Sql.so.5)
    linux-vdso.so.1 (0x00007fff23f74000)
    libQt5DBus.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5DBus.so.5 (0x00007f2e54e20000)
    libQt5WebKitWidgets.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5 (0x00007f2e54dd9000)
    libQt5Xml.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Xml.so.5 (0x00007f2e54d9c000)
    libowncloudsync.so.0 => /opt/ownCloud/ownCloud/lib/x86_64-linux-gnu/libowncloudsync.so.0 (0x00007f2e544da000)
    libowncloud_csync.so.0 => /opt/ownCloud/ownCloud/lib/x86_64-linux-gnu/libowncloud_csync.so.0 (0x00007f2e5427b000)
    libqt5keychain.so.1 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libqt5keychain.so.1 (0x00007f2e54053000)
    libQt5Widgets.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f2e53a00000)
    libQt5WebKit.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5WebKit.so.5 (0x00007f2e51a23000)
    libQt5Network.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f2e51893000)
    libQt5Gui.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f2e51394000)
    libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f2e50c49000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f2e508c0000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f2e50522000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f2e5030a000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f2e4ff19000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f2e4fcfa000)
    libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f2e4faad000)
    libQt5PrintSupport.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5 (0x00007f2e54ce2000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f2e4f890000)
    libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f2e4f587000)
    libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f2e4f271000)
    libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f2e4f009000)
    libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f2e4edd7000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f2e4ea9f000)
    libxslt.so.1 => /usr/lib/x86_64-linux-gnu/libxslt.so.1 (0x00007f2e4e862000)
    libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f2e4e4a1000)
    libicui18n.so.60 => /usr/lib/x86_64-linux-gnu/libicui18n.so.60 (0x00007f2e4e000000)
    libicuuc.so.60 => /usr/lib/x86_64-linux-gnu/libicuuc.so.60 (0x00007f2e4dc49000)
    libQt5Sql.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007f2e4dbfe000)
    libssl.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 (0x00007f2e4d996000)
    libcrypto.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007f2e4d553000)
    libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f2e4d2b5000)
    libdouble-conversion.so.1 => /usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1 (0x00007f2e4d0a4000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f2e4cea0000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f2e54c86000)
    libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007f2e4cc1c000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f2e4c9aa000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f2e4c782000)
    liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f2e4c55c000)
    libicudata.so.60 => /usr/lib/x86_64-linux-gnu/libicudata.so.60 (0x00007f2e4a9b3000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f2e4a6ff000)
    libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f2e4a4d2000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f2e4a2ca000)
    liblz4.so.1 => /usr/lib/x86_64-linux-gnu/liblz4.so.1 (0x00007f2e4a0ae000)
    libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f2e49d93000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f2e49b8f000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f2e49989000)
    libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f2e49774000)
    libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f2e4955f000)

So why is ld finding the system library if all other Qt libraries it finds are the ownCloud versions? Why specifying LD_LIBRARY_PATH is not useful?

Tried to reinstall the ocqt5101-libqt5core5a package but that didn’t work either. Any clues?

Edit 1:

Tried to completely remove the libqt5core5a system package (and had to remove also all the KDE stuff with it) to see the difference. And I get a different error:

pavel@lenovo ~ $ LD_LIBRARY_PATH=/opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu owncloud
owncloud: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory

As already stated before, the file /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Core.so.5 is there and is a symbolic link to the right library. But it seems that all the other libraries are expecting it to be in the system library directory (/usr/lib/x86_64-linux-gnu). This library path may be hardcoded somehow in the other libraries because they are ignoring the file that lies in the same directory as themselves.

Does this mean that the ownCloud Qt packages are broken?

Edit 2:

Inspected another fully updated system with Linux Mint 19 Tara and with exactly the same official ownCloud repository. It’s an i386 system and there this bug doesn’t manifest.

Edit 3:

Mentioned this question on the ownCloud forum. With its users, we narrowed down the problem. It doesn’t have anything to do with the ld cache (see here).

Something has to be wrong with the ownCloud’s libQt5Core.so.5.10.1 library itself. But what?

Tried to install the Testpilot cloud client but the error persists (I suppose the library is basically the same).

Edit 4:

Found a dedicated Linux Mint 19 ownCloud repository on the openSUSE server and installed from there (see here) but the problem with the library still persists.

  • You can add additional paths to your libraries in a file in /etc/ld.so.conf.d/ add owncloud.conf with the LD_LIBRARY path (just the plain-full path) you've posted. Finally rebuild the library cache with sudo ldconfig -v this should rebuild the library cache - and you should find your QT libs in the printed output. – Michael D. Dec 5 '18 at 19:58
  • Thank you, @Michael D., for your comment. Tried what you suggested but the system library still somehow takes precedence: libQt5Gui.so.5 => /opt/ownCloud/qt-5.10.1/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f0f82f10000) libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f0f827c5000) – Cigydd Dec 5 '18 at 20:46
0

I think I got it. Tried to downgrade the ownCloud client to version 2.4.3 and it worked.

Should someone run into this situation here is a script for their convenience:

#!/bin/bash

apt remove owncloud-client
apt autoremove

sudo rm -f /etc/apt/sources.list.d/*own[cC]loud*.list

wget -nv https://download.opensuse.org/repositories/isv:ownCloud:desktop:client-2.4.3/Ubuntu_18.04/Release.key -O Release.key
sudo apt-key add - < Release.key
rm Release.key

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/isv:/ownCloud:/desktop:/client-2.4.3/Ubuntu_18.04/ /' > /etc/apt/sources.list.d/isv:ownCloud:desktop:client-2.4.3.list"

sudo apt-get update
sudo apt-get install owncloud-client

I think that my ancient kernel (3.13.0-98) doesn’t play well together with the latest 2.5.* versions of the ownCloud client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.