0

I have a very strange issue. At the moment in which udev is loaded (during boot), the video signal is lost on the display if the HDMI port has no screen attached to it (the display is connected to a USB-C port carrying the DisplayPort interface).

Additional tests show that a screen must be connected to the HDMI port at the moment udev starts, otherwise no signal appears through any of the two USB-C and HDMI ports when connecting a screen later on (a reboot is then necessary). This is true with whatever configuration I use (no screen connected during boot / one screen connected through HDMI and manually disconnected just before udev starts / one single screen connected on the USB-C port during boot / ...). In such cases, I managed however to ssh to the machine and check that it booted properly. Even Xorg seems to be running properly.

It is very annoying, since I wish to have the display communicating through the DisplayPort via USB-C, which is the only configuration allowing for a daisy-chain connection of multiple monitors. The work-around at the moment is to connect a screen through HDMI during boot, and change the configuration after boot.

I have already tried things like

echo detect > /sys/class/drm/card0-DP-1/status

after boot when nothing was plugged to the HDMI port, which produces

cat /sys/class/drm/card0-DP-1/status
connected

but will still keep the screen without any signal (on HDMI or USB-C).

Hardware:

  • Intel NUC NUC7i7BNH
  • Intel Iris Plus graphics card

Software:

  • Linux kernel 4.14.78
  • Intel driver i915 (from the kernel)
  • Slackware 14.2 distribution

Maybe some kernel module has a parameter that would force the use of some given port (HDMI/USB-C)? I did not find any information on the web regarding this possibility.

Thank you for any ideas!

0

At boot the device may not register as a screen (as it is USB-C) hence your need to plug the screen in directly via an HDMI port first to allow it to boot.

There are ways to enable "headless" mode and still be able to use your monitor (IIRC). That may be something to look into.

  • This is a very clear formulation of what I guess the problem is, and what I think the correct workaround might be. It however does not answer at all to the main question, which is, how to implement this solution in Linux with the i915 Intel driver? I've looked quite a bit on the Internet, without finding any hint, but I might not have tried searching with the appropriate keywords... – calvofl0 Dec 6 '18 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.