1

I must update OpenSSH on my RHEL 5.5 because of CVE-2018-15473. My OpenSSH version is OpenSSH_4.3p2 and must be update to OpenSSH_7.9, when i want to do this i get that message when using configure command

checking OpenSSL library version... configure: error: OpenSSL >= 1.0.1 required (have "0090802f (OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008)")

so i download OpenSSL_1.0.1a and try to install it, when i use make test command

after ./config and make i get that error at the end

error
make[1]: ** [test_cms] Error 1
make[1]: Leaving directory `/u01/install/openssl-1.0.1p/test'
make: ** [tests] Error 2***
So... How can i update my OpenSSL and then update OpenSSH???

I cant connect my linux os to internet

1
  • 1
    The error(s) that you omitted above test_cms are the ones that answerers would need.
    – Jeff Schaller
    Commented Dec 5, 2018 at 10:44

1 Answer 1

2

I solved my problem with the below string of commands:

Download the latest version of the OpenSSL source package:

wget ftp://ftp.openssl.org/source/openssl-1.0.1g.tar.gz

Install OpenSSL 2 & openssh-7.9p1:

  1. tar xzvf openssl-1.0.1g.tar.gz

  2. tar -zxvf openssh-7.9p1.tar.gz

  3. cd openssl-1.0.2p

  4. ./config shared zlib

  5. make install

  6. mv /usr/bin/openssl /usr/bin/openssl.OFF

  7. mv /usr/include/openssl /usr/include/openssl.OFF

  8. ln -s /usr/local/ssl/bin/openssl /usr/bin/openssl

  9. ln -s /usr/local/ssl/include/openssl /usr/include/openssl

  10. echo "/usr/local/ssl/lib" >> /etc/ld.so.conf

  11. ldconfig -v

  12. openssl version

  13. cd openssh-7.9p1

  14. /configure --with-ssl-dir=/usr/local/ssl/bin/openssl

  15. make

  16. make install

  17. sshd -version

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .