1

I'm not able to manage this error

[  666.695694] wlan0: deauthenticating from xx:xx:xx:xx:xx:xx by local choice (Reason: 3=DEAUTH_LEAVING)

I obtain the error only when I'm trying to connect to a WPA2-Enterprise network (EAP-MSCHAP2). Other connections work well without any error. This error has been obtained after a Linux upgrade, at now I'm using

Linux root 4.18.0-kali2-amd64 #1 SMP Debian 4.18.10-2kali1 (2018-10-09) x86_64 GNU/Linux 

Lurking I've seen a possible cause to this problem: the TLSv1.2 support has been disabled. I've seen several solutions with wpa_supplicant, but I'm using network manager. I've also tried to configure wpa_supplicant without any result. What can I do?

  • Ummm......network manager is just a front-end for wpa_supplicant. Debian even took the words right out of my mouth: "NetworkManager is also a front-end for wpa_supplicant." wiki.debian.org/WiFi/HowToUse#wpa_supplicant – bgregs Dec 6 '18 at 21:25
  • Ok, but I don't have a wpa_supplicant.conf file and all my network configurations are in in /etc/NetworkManager/system-connections. All "workarounds" found are based on a modification of wpa_supplicant.conf – Rtmd Dec 7 '18 at 9:05
  • Maybe I'm wrong but I've understood the problem but I'm not able to find a solution – Rtmd Dec 7 '18 at 9:07
  • 3
  • Not a duplicate: I don't have an interface with a long name. My interface is the standard wlan0 – Rtmd Dec 8 '18 at 9:20
0

I have the very same problem. wpa_supplicant not connecting anymore to eduroam

We should try to figure out what package update introduced this bug and either revert it to the previous version or fix it.

Update: I found that the 25th of november libssl got updated in debian testing/unstable to version 1.1.1a-1. wpasupplicant, instead, hasn't been updated since August.

I tried to downgrade both and actually the problematic one is wpasupplicant. Try to install the older version by:

sudo apt-get install wpasupplicant=2:2.4-1+deb9u2

then mark it hold with:

sudo apt-mark hold wpasupplicant

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.