2

I have an i7 laptop built in 2010/2011 with 8GB RAM. I moved its original HD & OS, Ubuntu 10.04, to an external USB enclosure - booting from this provides me with an outdated but stable system.

In place of the old HD, I have put in a new SSD brand and name suggested to me by system76 support.

I just about successfully installed Lubuntu 18.04 from a USB stick for a minimal installation. I battled with system crashes before and after the install, fortunately not during the install.

After the install, I have been able to have a running system once for about 10 minutes, other times mere seconds, and yet other times crashes happen during the boot process (on a number of occasions the system crashed before the BIOS splash screen even displayed, some crashes occurred before the GRUB2 menu displayed, some after the menu displayed, but before OS selection, some shortly after OS selection, some later, some just before the login screen appeared, some after, and few after login).
I had to use dpkg --configure -a twice after two random crashes following apt update+apt upgrade (during the upgrade), and then I still needed to redo apt update+apt upgrade to finish the upgrade.

Just to say that I see no pattern.
It even crashed when I logged in in console mode (graphics was started, but I did not use it, Ctrl-Alt-F1 brought me to tty1).

The actions I attempted are:
1. making sure the microcode was up to date, dmesg now shows (after several reboots) a microcode revision 0xa dated 2018-05-08.
2. configuring /etc/defaults/grub with GRUB_CMDLINE_LINUX="amdgpu.dc=0" (as seen somewhere on the net)
3. configuring my /etc/fstab with noatime for / and /boot, to limit SSD writes

None of these actions however seem to have any effect on the frequency or randomness of the crashes.

For investigation or configuration purposes, I can mount my new partitions from an Ubuntu 16.04 Virtual Box VM from my old system.

I have not been able to find any reason for the crashes in any of the logs, but maybe I am looking for the wrong thing in the wrong place (/var/log)?

Booting from USB stick (live ISO / multiboot) with a variety of images leads to similar system instability: tried Antergos (can't even boot), Manjaro (can't install), Mint19 and Lubuntu (yes, even the one I finally successfully installed).

I am now looking for more things to investigate or configurations to solve these very frequent crashes - which given my old OS stability, I do not believe are hardware related - other than maybe related to the SSD.

EDIT:
I have now tried Ubuntu 18.04 and 14.04 from live USB stick, installed on the new SSD, and installed on another old 30GB HDD in a USB enclosure. All 6 options suffer from the same instability.

I have also cloned my old Ubuntu 10.04 original HD to the SSD, this boots without a hitch & stays stable. Ubuntu 10.04 is also stable from the live USB stick.

I contacted my PC manufacturer's fantastic support, and like me they come to the apparently only possible conclusion that the GPU is the problem as it is not supported by modern drivers.

The GPU is an ATI MOBILITY RADEON HD 5870 Graphics with 1GB GDDR.
If anyone has a kludge, a configuration (GRUB & OS) or a fix they can share, to make my new OS's work with this old graphics card, I'd love to hear from you.

AMD do not seem to offer much support for old hardware on Linux.

closed as too broad by Rui F Ribeiro, RalfFriedl, G-Man, JigglyNaga, Stephen Harris Dec 5 '18 at 11:33

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    "I do not believe are hardware related - other than maybe related to the SSD" Bingo! Given the system sometimes crashes even before the bootloader starts, the problem is not with Linux. Hence you can focus your troubleshooting efforts on the SSD. – Emmanuel Rosa Dec 5 '18 at 1:33
  • 1
    An easy test to see if the cause of the problem is SSD hardware trouble, or trouble with newer OSs, is to install your old Ubuntu 10.04 on the SSD, and see what happens when you boot it from the SSD. – dirkt Dec 5 '18 at 7:15
  • Good suggestion, I thought about it, but the simplest way to do it is to dd my old drive to the new one and for this to happen I need to boot from USB which is equally unstable! – asoundmove Dec 5 '18 at 10:58
  • Ok, I have now cloned my old HD to the SSD. The system boots and is stable, so that proves the SSD is not the problem. – asoundmove Dec 7 '18 at 20:19
2

Try using IDE mode https://odd.blog/2013/11/26/yes-finally-fixed-ssd-freezing-computer/

Try updating your bios.

Try installing your new operating system on a spinning hard drive.

on a number of occasions the system crashed before the BIOS splash screen even displayed

That clearly points the finger at bios ssd incompatibility. I have heard that some new drives are so fast or so power sipping they break old controlers.

  • Hmm, thanks for the food for thought, but the whole point of having an SSD is to go faster than IDE bandwidth! I'll try though and see how it goes. I would like to try disabling LPM as suggested in the post you refer to, but I have not found a way to do so with Linux. Installing on a spinning HD however will hard as I do not have a spare one to hand. – asoundmove Dec 5 '18 at 10:53
  • My BIOS only offers AHCI, IDE is not an option available to me. I changed vm.swappiness to 2 in sysctl.conf and went through a straightforward boot, but maybe it's only a coincidence as the system crashed again less than a minute after login! – asoundmove Dec 6 '18 at 11:14
  • See theedits: new OS on old HDD: fails. Old OS on SSD: success. So the SSD is not the culprit. It seems that the graphics card is. Any idea how to work around or fix this issue? – asoundmove Dec 7 '18 at 20:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.