0

I recently installed Linux Mint 19 onto my Dell XPS 15 laptop with Windows 10 pre-installed. The initial install of Mint seemed to go fine. I booted off of a live USB and installed Mint onto a partition which I had freed up earlier. However, after restarting my laptop, there was no option to boot the Linux OS; the system simply starts Windows as usual. I have checked the boot sequence in BIOS, and Mint is nowhere to be found. Despite this, when looking at the partitions in Windows, it does say that Mint is in fact installed on the given partition. I should also add that I am in UEFI mode and secure boot is off.

  • This appears to have been addressed in a different post: askubuntu.com/questions/281200/… – dwitit275 Dec 5 '18 at 2:25
  • Although the post is similar, I believe the difference here is that I am able to install GRUB successfully (done manually on the LiveUSB), but despite this, the option to boot Linux does not appear, even though I have installed it. – Nathan Dec 5 '18 at 17:44
1

I had a similar situation when running in UEFI mode and dual booting Windows and Linux. Some firmwares give the path '/efi/microsoft/boot/bootmgfw.efi' more precedence than /efi/boot/bootx64.efi in the EFI system partition. Bootmgfw.efi is the name of the microsoft bootmanager, hense my reasoning for it prioritizing that path over the traditional bootx64.efi. As a solution, I renamed the windows bootloader and configured grub to load it.

However, Windows Updates will replace it sometimes, so I often had to mount the partition in windows and rename the file again.

0

Turns out I was performing the installation in Legacy mode. Upon switching to UEFI, everything worked correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.