1

I installed FreeBSD 11.2 on my DELL Latitude E7470 with UEFI (might be important). By default it does not install a GUI and that is fine by me (for now). Using the <Alt>+<Fn> keys I can switch between different virtual terminals.

I'm stuck with a 1920x1080 screen resolution

This results in way too small characters for me to read comfortably.

  • I tried enterind mode 0 in /boot/loader.conf to switch to 800x600 mode but that does not work. It does work however when I press the <Esc> key during boot and enter it at the boot prompt.
  • Using gop set <n> crashes the laptop, i.e. the screen goes black and the laptop does not respond to any keys anymore.

Anyone has any ideas on how to fix this?

  • Interesting question, unfortunately I can't say I have a direct answer, but it does appear you are looking in the right place (i.e. loader.conf). Check out the bottom of this bug report and see what the users' resolution was, hopefully it can help. Possibly add "mode 0" to /boot/loader.rc.local (you may have to create that file)? forums.freebsd.org/threads/kernel-boot-resolution.53150 – bgregs Dec 4 '18 at 16:08
  • related? unix.stackexchange.com/questions/361243/… Would "mode 2" work? – Rui F Ribeiro Dec 4 '18 at 17:17
  • mode 2 doesn’t work either. The file /boot/loader.rc.local is not referenced anywhere. The file /boot/loader.conf.local is though. But that file is no different than the one I was already using. In addition, setting mode also prevents the commands behind it from executing. Since I had my WLAN config in the file behind the mode command, my wifi card stopped working. So FreeBSD clearly doesn’t like the command. – Tommiie Dec 4 '18 at 19:39
0

The way to change the resolution of the kernel virtual terminals is the vidcontrol command. The -i mode option causes it to display a table of available video modes. Make the chosen mode setting be applied at bootstrap by setting the allscreens_flags variable in /etc/rc.conf.

Further reading

| improve this answer | |
  • I tried that already but the command lists no available modes. I will read the two linked articles. Thanks. – Tommiie Dec 5 '18 at 7:06
  • kldload vesa from the first link gives an error: sysctl_unregister_oid: failed to unregister sysctl – Tommiie Dec 5 '18 at 7:18
0

It's possible your video card is not supported by the default vt driver. Switch to sc by placing this in /boot/loader.conf

hw.vty=sc

Reboot, login, and try vidcontrol -i mode again.

Thanks to protocelt on FreeBSD forums

| improve this answer | |
  • Could be. I don not use FreeBSD anymore as my daily driver on the laptop so I cannot check whether this is the case or not. – Tommiie Sep 8 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.