3

In Ubuntu 18.10 I can't use the trash on my NTFS partition. When deleting a file Nautilus prompts to permanently remove it. In Solus trash works on this partition.

Any ideas how to enable trash or what other info could I provide?

My setup:

  • fstab entry: /dev/disk/by-uuid/530B3F8539F30AB8 /mnt/Daten auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Daten,uid=1000,gid=1000 0 0

  • gvfs is installed

  • ll shows drwxrwxrwx rights on /mnt/Daten/

What I tried:

2
  • please check whether currently logged in user id is 1000 or not. you can check it with id command. uid must be fine, you wont need gid parameter. – Derviş Kayımbaşıoğlu Dec 3 '18 at 13:33
  • yes, id prints uid=1000; ok thx – jl005 Dec 3 '18 at 16:00
0

I know this is 1 year+ old but; If someone in the future would need this:

To enable "delete-permanently button":

gsettings set org.gnome.nautilus.preferences show-delete-permanently true

To disable "delete-permanently button":

gsettings set org.gnome.nautilus.preferences show-delete-permanently false

//Best Wishes!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.