0

i try to setup kubernetes cluster on atomic fedora. I tried atomic fedora 27, 28 and 29 but I am facing same error on every release. Running kubeadm init ends with following error:

failed to parse kernel config: unable to load kernel module "configs": output - "modprobe: FATAL: Module configs not found in directory /lib/modules/4.19.5-200.fc28.x86_64\n", err - exit status

I have tried to install the kernel-headers and kernel-devel, dracut regenerating, but nothing solved the issue. Do you have any idea how to solve it? And more important qustion, does someone have any idea what is causing the problem and what I am doing wrong?

Is this caused by the operating system or rather than misconfigured kubernetes? I just tried to follow the atomic docs.

2

kubeadm is looking in the wrong place for the kernel config (at least, based on where fedora atomic puts it). That'll eventually be fixed by this, but for now you need to append --ignore-preflight-errors=all to kubeadm init.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.