I cannot install anything or upgrade my system. I tried using solutions in the various other answers linked above, but they did not work. I tried to purge the package libkf5auth-dev, but it was a dependency of libkf5configwidgets-dev and libkf5configwidgets-dev is a dependency of many other packages of my system. I am running KDE Neon based on 18.04 LTS, but I never had any sort of issues with aptitude before this.

When i run sudo apt upgrade, it gives me this output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libkf5auth-dev : Depends: libkf5auth5 (= 5.52.0+p18.04+git20181118.0151-0) but 5.52.0+p18.04+git20181130.1300-0 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

When I run sudo apt --fix-broken install, it gives me this output: https://pastebin.com/5DSJKV0S

Running apt-cache policy libkf5auth5 libkf5auth-dev libkf5configwidgets-dev gives me this output: https://pastebin.com/QuX1gYa8


The first pastebin says (at the bottom):

[...] trying to overwrite '/usr/lib/x86_64-linux-gnu/cmake/KF5Auth/KF5AuthToolsTargets-debian.cmake', which is also in package libkf5auth-bin-dev:amd64 5.52.0+p18.04+git20181118.0151-0" 

This appears to be your direct problem.

The wider problem is you're using one day old git packages, unless you really know what you're doing that's a bad idea.

sudo apt purge libkf5auth-bin-dev:amd64

or if that fails then use dpkg:

sudo dpkg --force-all --remove libkf5auth-bin-dev

and then you should be able to do the upgrade. Caution: dpkg will remove a package when you "force" it even when that hoses your system and leaves it unusable; take care!

sudo apt install libkf5auth-dev

But note that as you're installing recently developed packages they may have bugs, including bugs in the packaging itself, such as unsolvable dependency issues that apt simply can't resolve consistently. It may not be possible to install those packages with apt.

  • I tried that; it did not work. I am unsure what you mean by day old git packages. Also, running sudo apt purge libkf5auth-bin-dev:amd64 gives me the same output as always pastebin.com/LVgWdktW – driveforms Dec 2 '18 at 22:14
  • You're installing packages that came from git 2 days ago, they're in active development, they're likely to have problems (eg dependencies are wrong). Have you tried removing like sudo dpkg --force-all --remove libkf5auth-bin-dev? Note that it may not be possible to install the 30th November 2018 packages and have apt consider your system consistent if the package internal dependency info is wrong. – pbhj Dec 2 '18 at 23:11
  • Ahh, that fixed! I tried sudo apt-get --force-yes purge libkf5auth-bin-dev before, but it did not work and complained about the same dependency issue (depends on package x-0131, but x-1300 is installed) – driveforms Dec 2 '18 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.