1

I'm running emacs -nw in console mode inside the KDE konsole terminal emulator. In Emacs I have defines Shift-Left and Shift-Right from the windmove package to jump horizontally between buffers. The problem I see is that konsole seems to swallow the Shift-Left and Shift-Right keys. The Shift-Up and Shift-Down keys are working. I read the keys received by Emacs with Ctrl-h l and can see that no keys are received for Shift-Left and Shift-Right however I get keys for Shift-Up and Shift-Down.

On the other hand I can run Emacs inside xterm as well es Emacs inside gnome-terminal and receive the right keycodes for Shift-Left and Shift-Right:

 ESC [ 1 ; 2 C [windmove-right]
 ESC [ 1 ; 2 D [windmove-left]

It seems like KDE Konsole is handling the Shift-Left and Shieft-Right keycombinations itself and is not forwarding them. I went into Settings->Edit-CurrentProfile->Keyboard and edit the "Default (XFree 4)" profile. However defining Shift-Left and Shift-Right there doesnt take effect:

   Right+Shift \E[1;*C
   Left+Shift  \E[1;*D

and test in the "Input" dialog then it seems to yield the right output:

enter image description here

However if I apply the settings and enter Emacs again I don't receive any characters for Shift-Left and Shift-Right. I also tried adding -AppScreen and +AppScreen but same result.

On the other hand I can see the mapping for Shift+Up and Shift+Down in the "Default (XFree 4)" profile:

   Up+Shift    ScrollLineUp
   Down+Shift  ScrollLineDown

These Keycodes reach Emacs in the form of:

  ESC [ 1 ; 2 A [windmove-up] 
  ESC [ 1 ; 2 B [windmove-down]

Does anyone know why Shift-Left and Shift-Right are handled specially and howto get them work?

1 Answer 1

3

They are also defined as global Konsole shortcuts to switch to the previous/next tab. Go to Konsole's Settings -> Configure Shortcuts and remove them there.

(I performed this first, followed by the step you described. I also had to restart konsole for the changes to take effect; not sure if you'll need to restart too.)

1
  • Or Yakuake shortcuts. On my case, Yakuake was redifining Shift+Left Shift+Right
    – Zardoz89
    Jan 9, 2019 at 12:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .