4

On Ubuntu, I have a problem to establish a connection to redis server using SSH tunnel and SSH key with Redis Desktop Manager (RDM).

What are the symptoms?

  • I can connect to the server where redis is running using "plain" ssh and my id_rsa,
  • other utilities which use either the SSH agent or keys in .ssh can connect to this server and create tunnels (e.g. DB apps),
  • I can connect with RDM to redis servers using SSH tunnel and password (so the question is not a duplicate of Unable to establish an SSH tunnel using Redis Desktop Manager); but this is not a perfect solutions, because I would rather use private/public keys authorization,
  • I cannot convert keys in .ssh to a working PEM format required by RDM: any PEM files I've generated using different methods I googled are rejected by RDM with a message Connection: Disconnect on error: SSH Connection error(Authentication Error): Unable to extract public key from private key file: Unable to open private key file,
  • I tried entering either a path to id_rsa (~/.ssh/id_rsa) or just a path to a directory where my private key is stored (~/.ssh).

So, does anyone have an idea how to properly convert my SSH keys to a PEM format RDM needs and accepts?

3
  • Can openssl read the private key? Please do not post the results, but run the command openssl pkey -in ~/.ssh/my_key.pem -text .... And what format does the key say it's in... Do post this result grep BEGIN ~/.ssh/my_key.pem Commented Dec 2, 2018 at 12:57
  • yes, openssl can read the file, grep returns -----BEGIN RSA PRIVATE KEY----- Commented Dec 3, 2018 at 22:59
  • I'd like to add, that I tried to put both public and private key into the same file. I did not work as well. Commented Dec 3, 2018 at 23:00

2 Answers 2

7

That's a known issue of RDM: https://github.com/uglide/RedisDesktopManager/issues/4230

Workaround: copy your id_rsa file into a directory without "." in its name...

1
  • Please note, that the file must not be sym-linked. It has to be copied or hard-linked. Commented Dec 5, 2018 at 15:33
1

If you installed rdm as a snap you will need to run the following command.

sudo snap connect redis-desktop-manager:ssh-keys

This is documented at http://docs.redisdesktop.com/en/latest/install/#ubuntu-archlinux-debian-fedora-centos-opensuse-etc which is linked to the Github issue at https://github.com/uglide/RedisDesktopManager/issues/4230 which is in the solution provided by @nimai

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .