0

This question is an exact duplicate of:

I'm having trouble with the command: sudo apt-get update ,when I run it, I get the following message:

Err:1 http://http.kali.org/kali kali-rolling InRelease
Connection failed [IP: 192.99.200.113 80]
Reading package lists... Done
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/InRelease     Connection failed [IP: 192.99.200.113 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.

With: sudo nano /etc/apt/sources.list i get:

deb http://http.kali.org/kali kali-rolling main non-free contrib

I've already tried to disable antivirus and firewalls without success. I also followed the solution of the post error update in Kali following all the steps proposed. Tried uninstalling the app and reinstalling it. What do you recommend?

marked as duplicate by Rui F Ribeiro, dirkt, jordanm, RalfFriedl, Stephen Harris Dec 2 '18 at 4:06

This question was marked as an exact duplicate of an existing question.

  • 1
    Do tcp connections fail to that server in general, or is it specifically package stuff? Run curl http.kali.org If you get a bunch of html back then you can at least talk to the server. If not, then the apt stuff isn't relevant to your problem (but the error message might be). – MatrixManAtYrService Dec 1 '18 at 16:12
  • 1
    Wait. You are trying to run Kali packages on Windows subsystem for Linux? Did I understand that correctly? And you expect it to work (once you actually download packages)? – dirkt Dec 1 '18 at 16:44
  • @MatrixManAtYrService i can ping to 192.99.200.113, the output of curl is: curl: (52) Empty reply from server – Enzo Dec 1 '18 at 18:07
  • @dirkt Yes, because it usually works. – Enzo Dec 1 '18 at 18:10
  • When I curl that address I get a string back: <!DOCTYPE HTML.... It looks like something on the windows side is preventing outbound connections on 80 (probably a firewall). Once you fix this, the package stuff should start working. Maybe you will find something helpful here: github.com/Microsoft/WSL/issues/5 If not, I'd try asking someplace that deals specifically with WSL. We'd love to help, but this is probably not that place. – MatrixManAtYrService Dec 1 '18 at 20:28
1

Copied from the question into an answer:

Problem solved. I switched off the port 80 and port 443 monitoring in Kaspersky settings then it works. Thanks a lot

Not the answer you're looking for? Browse other questions tagged or ask your own question.