2

Using Elementary OS 5 Juno. I have tried to install discord earlier and had the same problem, I download the .deb that supposedly should simply open the gdebi package installer, and it does, then I click install package and it closes without doing anything, I had to try for a few hours different things to get discord installed, now I am trying to install Visual Studio Code and I have the same issue, I download the .deb, click install package and the software is just like "thank you for clicking on install, I will just close without throwing any error nor any tips on why I refuse to install your package"

4
  • 1
    try sudo apt install /path/to/any.deb in terminal. Nov 30 '18 at 18:08
  • ~/Downloads$ sudo apt install code_1.29.1-1542309157_amd64.deb Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package code_1.29.1-1542309157_amd64.deb E: Couldn't find any package by glob 'code_1.29.1-1542309157_amd64.deb' E: Couldn't find any package by regex 'code_1.29.1-1542309157_amd64.deb' Nov 30 '18 at 18:11
  • gDebi still does not work well with ElementaryOS. They have an app in the store called Eddy that does this. appcenter.elementary.io/com.github.donadigo.eddy Aug 12 '20 at 3:11
  • have you tried to run this from the directory: sudo gdebi code_1.29.1-1542309157_amd64.deb thats how i installed mine earlier today
    – sorcerer
    Nov 22 '20 at 7:39
2

I have managed to fix by doing

sudo apt install ./code_1.29.1-1542309157_amd64.deb

but I don't get what is the point of gdebi if it just can't install my packages.

2
  • Linux is the kernel, you have problems with your distribution called Elementary. (which is a small project and i don't recommend to use) So Linux, the kernel is very good at its own and doesn't require any improve. Report the bug for improve your distribution: reddit.com/r/elementaryos/comments/5810mb/… Nov 30 '18 at 18:20
  • I actually had the same problem with Ubuntu, so this is an Ubuntu problem apparently since Elementary is Ubuntu based, but my point is all distros are not beginner friendly, they all require some terminal usage which is why I prefer to be away from it. On my servers it is ok to use linux, I use CentOS on them, I have no choice but to use a terminal and that is perfectly fine, but on my personal computer I wish I could just do things without thinking... Nov 30 '18 at 18:26
0

sudo apt-get update may fix it

0
0

no. it doesnt. I can't figure it out. If you run it from the terminal- it works. You can get eddy from the app store and it will do the same thing... but it doesn't tell you what other packages it is fetching first which is one of the nicest parts of gDebi. :/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.