1

I've just installed Debian 9 and bluetooth can be turned on / off, I can also search for devices, however, it doesn't find any devices at all.

During the OS startup, I'm getting these messages: enter image description here

root@debian:/home/ilya# dmesg | grep -i blue
[    5.802583] usb 2-4: Product: Bluetooth Radio 
[   13.847857] Bluetooth: Core ver 2.22
[   13.847873] Bluetooth: HCI device and connection manager initialized
[   13.847875] Bluetooth: HCI socket layer initialized
[   13.847877] Bluetooth: L2CAP socket layer initialized
[   13.847882] Bluetooth: SCO socket layer initialized
[   14.330088] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[   14.330090] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   14.586509] bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
[   14.586513] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   14.586519] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[   14.586521] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   14.651453] bluetooth hci0: firmware: direct-loading firmware rtl_bt/rtl8723b_fw.bin
[   14.652068] Bluetooth: hci0: rom_version status=0 version=1
[   14.652074] Bluetooth: cfg_sz 0, total size 22496
[   23.658112] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   23.658116] Bluetooth: BNEP filters: protocol multicast
[   23.658125] Bluetooth: BNEP socket layer initialized
[   38.947622] Bluetooth: RFCOMM TTY layer initialized
[   38.947627] Bluetooth: RFCOMM socket layer initialized
[   38.947633] Bluetooth: RFCOMM ver 1.11
[ 4363.037311] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[ 4363.037317] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[ 4363.058517] bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_config.bin (-2)
[ 4363.058524] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[ 4363.058527] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
[ 4363.058530] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[ 4363.059275] Bluetooth: hci0: rom_version status=0 version=1
[ 4363.059282] Bluetooth: cfg_sz 0, total size 22496
1

From https://github.com/lwfinger/rtlwifi_new/issues/158 by lwfinger, as of October 2016:

It is not an error. The latest Realtek BT device needs a "patch" file for the firmware. When the code to load that file was added, the hooks that might be needed in the future were added at the same time. Nothing is wrong as the BT part of the RTL8723BE does not need such a file.

[some discussion omitted]

[...] I have proposed a change that will only print a missing config file message only if the driver needs such a file. At the moment, only the RTL8822B needs such a file, and I do not think it has been released yet. In any case, the code will be changed soon.

However, the Armbian github has a rtl8723b_config.bin file available: direct download link here.

You might try downloading that file and placing it into /lib/firmware/rtl_bt directory; perhaps Realtek has produced a modified revision of that chip that needs the patch file after all. (If so, then it's apparently done without incrementing any of the obvious hardware version numbers... unfortunate, but hardware manufacturers do that sometimes.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.