1

I am trying to install Debian in ASUS P2440UA laptop. Previously I was using Windows 7 and Linux Mint in dual boot without any issue (for 6 months). But I decided to format whole hard drive and install only Debian. I have formatted the hard drive as GPT and tried to install Debian in UEFI mode. I used 256 MB EFI system partition, 60 GB root and 4 GB swap. Rest of the space is mounted as home. But at the end of installation process "failed to install grub bootloader on a hard drive". Then I have followed this https://forums.kali.org/showthread.php?37091-GRUB-Boot-Loader-Not-installing-on-Hard-Drive but still didn't worked. It was an "input output error". Then I have found this When wouldn't you want to install GRUB bootloader? saying that installing grub in a modern computer is not the best option.

In this case what is the best option for me? I am trying for four days. Note that I havd an empty hard drive. I want to use gpt format for hard drive. I will use multi boot.

8
  • "input output error" means you should replace your hdd (or the broken cables). – Ipor Sircer Nov 28 '18 at 15:05
  • Nothing is broken. Everything was working just fine. But I am having issue while trying to install only Deviation. – Nafi Shahriyar Nov 28 '18 at 15:21
  • "input output error" or grub cannot 'talk' to the drive for some reason. Can you use BIOS mode not UEFI mode as a test? – jc__ Nov 28 '18 at 17:19
  • Yes I did. BIOS mode works – Nafi Shahriyar Nov 28 '18 at 17:52
0

My problem was poor implementation of UEFI by ASUS in my ASUS P2440UA laptop. While trying to find a solution I have found in many documents that UEFI standed is not strictly maintained by manufacturers. I have found a way to install Debina in UEFI mode but I can't consider it as a solution.

Solve

  1. Install Windows 7 in UEFI mode. But windows 7 won't boot and will get stuck at logo. To boot windows, I had to enable CSM support to boot windows 7. (Ignore sda4 and sda9) Windwos 7 installed in UEFI mode
  2. Then I have installed Debian as usual in UEFI mode. Dualboot Debian with Windows 7
  3. Then I have deleted sda4, boot Debian from live USB, moved sda8 (Debian root partison) to free space on right side.
  4. Then I have mounted sda2 (UEFI bootloader partison) and deletd a folder named Microsoft. It contained windows bootloader. After that

sudo update-grub

  1. Then I have also deletd sda1. Now everything is working as I wanted. Current state
0

From the info you provided, GRUB may not be the issue. It might be a poor implementation of UEFI by the computer manufacturer. Attempting to manually reinstall or fix GRUB would not help if this is the case.

Try installing rEFInd onto a USB drive and booting it (assuming your computer can boot from USB). Follow the instructions and links at http://www.rodsbooks.com/refind/ to download and install. I recommend using the USB image file. There's a good chance rEFInd will find your Debian installation and kernel image and present an option to boot it.

Afterward, if you want rEFInd as a permanent solution:

  1. log into Debian and get sudo/root access
  2. mount the rEFInd USB drive, open it, and cd into EFI/
  3. copy the "refind" folder and paste it to your system's /boot/efi/EFI directory (make sure your ESP is mounted at /boot/efi). This will prepare us to "install" rEFInd using EFI shell.
  4. Reboot computer and boot the rEFInd USB drive again
  5. Choose the EFI shell option
  6. Follow the instructions to install via EFI shell here: http://www.rodsbooks.com/refind/installing.html#efishell This will update the nvram/computer's boot options with an entry pointing at Debian.

You may run into root access issues that need fixing first before you can install rEFInd on the main system. In my own experience, Debian's install process didn't enable root access despite me confirming otherwise. I'll leave this for some other time. As to why Windows and Mint worked before, if they were both on the same ESP, I'm guessing the UEFI detected Windows's presence and so was able to see other systems. If Windows was not present, it wouldn't have seen Mint (and therein lies the problem).

I had to do a lot of research for this because I'm assuming few people own hardware with poor UEFI firmware, so this issue is rarely reported and asked about. This is my two cents in order for me to give it more exposure. I hope I was able to help. I'm definitely not a Linux expert so feel free to correct anything I may have wrong. Anyway, good luck!

1
  • You are correct. It was manufacturing issue. I have heard about it while trying to find a solve, but I didn't expect it from a reputable company like ASUS. I have also upgrade ASUS UEFI firmware. I have successfully installed Debian in UEFI mode but I canty consider it as a solution. – Nafi Shahriyar Dec 5 '18 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.