0

I am using Orange Pi Zero and running Armbian Stretch OS 5.59 on it.

Problem is, it is giving wrong date and time even in the presence of the Internet. I have tried restarting "ntp" service but to no avail. I have also tried rebooting, but the same annoying result. I have already set the right timezone which is PKT, but it shouldn't matter. So what do I need to do or change?

Thank you.

  • 1
    Please define what wrong time is and what commands/configurations you have done to try to fix it. If it should not matter, why talking about it, then? I recommend being consistent. – Rui F Ribeiro Nov 27 '18 at 8:41
  • It showed time from September when I executed the "date" command. I tried the solutions above that I believed would relieve the problem, but no. – Saad Abdul Majid Nov 27 '18 at 9:53
  • Does it run ntpdate or similar to step the time before starting ntpd? – Kusalananda Nov 27 '18 at 10:23
  • Unit ntpdate.service could not be found. The above is the response to "service ntpdate status". So, I assume there is no such service running in my system. – Saad Abdul Majid Nov 28 '18 at 11:10
0

Now that I have resolved the problem, I want to share it with others. I had to make changes in "/etc/resolv.conf". Here nameserver field stated "127.0.0.1", I changed it to google nameserver "8.8.8.8". The problem resolved and I have correct date and time now.

But now that I see again, "/etc/resolv.conf" has been overwritten by OS(I believe) and it again displays "127.0.0.1" as my nameserver. But, still I am getting the right date and time. My take is, I needed to coordinate with Google to update correct date and time. But upon reboot, OS retraces any changes made in "/etc/resolv.conf" but changes stick.

  • 1
  • You seem to be talking about two related problems, and the question being a symptom of a related problem and not a cause per se. – Rui F Ribeiro Nov 27 '18 at 11:54
  • @RuiFRibeiro they are not related, I think. Because when I was about to edit "resolv.conf", it was written exclusively that my changes could be retraced. – Saad Abdul Majid Nov 28 '18 at 11:05
  • @Kusalananda, I meant Operating System; Armbian in this case. – Saad Abdul Majid Nov 28 '18 at 11:06
  • I believe I was at fault with this approach. Can I ask what service is responsible for updating date and time when internet access is available in Armbian? – Saad Abdul Majid Nov 28 '18 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.