1

Just trying out BackInTime, not running as root, and when I've completed the initial configuration of settings I hit OK and... nothing happens.

I've got my destination base set to a dedicated partition, also used by Timeshift, at /mnt/backup. I think Timeshift mounts this partition when it needs to, and it was already mounted when I tried to run BackInTime.

Running as non-root, BackInTime doesn't seem to like this destination (it doesn't error, but doesn't move on from the settings dialog when I hit OK).

Running as root, it seems happy, and completes a quick single file test backup.

Do I just run as root, or do I need to get it running as non-root by mounting or addressing the backup partition differently?

2

Not sure if it helps, but I had similiar problems (hitting ok and nothing happens) when setting up backintime to backup to a ssh destination. To narrow down the problem, I would do the following:

  • Check that your user has read and write access to /mnt/backup
  • run backintime-qt4 from the commandline to see if any errors are reported there
  • run journalctl -f while hitting the ok button to see if there are any suspicious messages in there
  • run htop and filter for rsync to see whether backintime has started some commands

Best case, you figure out the commands that backintime is starting and you can run them yourself to get the error messages and start working your way from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.