0

I'm experiencing a bug in Manjaro Gnome that I hope to solve.

PC System and Drive Configuration:

Legacy BIOS system. ASUS Maximus IV Extreme-Z. This Motherboard supports UEFI BIOS boot in theory but activating EFI compatible ROM in options makes the system not able to boot to BIOS leaving only a black screen. This is not related with the present bug.

Sapphire RX 580 Nitro+. This card has a hybrid BIOS capable of booting with legacy and UEFI BIOSes. Its default mode is legacy. (Many users reported problems in forums with legacy BIOSes in the Sapphire 480 models).

sda SSD
    sda1 MS Windows Reserved
    sda2 Windows 10
    sda3 extended Manjaro
        sda5 /boot
        sda6 /
        sda7 /var
sdb SATA HDD
    sdb1 Windows data partition (sometimes appears boot in gparted options)
    sdb2 Manjaro Swap partition
sdc SATA HDD
    sdc1 extended Manjaro
        sdc5 /home
    sdc3 Windows data partition

Bug explanation:

Upon installing a new graphics card GRUB booted just fine. I entered Manjaro "Hardware Manager" and pressed "Automatically install open source drivers".

This installs "video-linux" drivers which include AMD open source drivers in the Manjaro distro.

Right after that I rebooted Manjaro and this somehow corrupted the boot and even messed the video resolution at BIOS producing this image when I entered BIOS config:

broken resolution BIOS screen

Installing a spare video card seemed to fix the problem and the image display at BIOS went back to normal with both the spare card and after re-plugging the RX 580.

After that I uninstalled the "video-linux" drivers during one of the few times Manjaro managed to boot but it didn't solve the problem.

The corrupted boot consist of several problems:

  1. The SSD sda is detected by the BIOS only sometimes. Many other times it randomly doesn't get detected. I checked the SSD health with "sudo smartctl -a /dev/sda" and it reports a healthy state with 96 the lowest score on a scale of 0/100.
  2. Trying to restore the GRUB as per this guide only worked a couple of times. The SSD seems to degrade with each boot. The first boot after applying the fix worked fine but at next boot this error returned and the boot corrupted again until eventually it can't boot anymore. Checked the sda5 /boot partition with fsck and it reports everything is OK as with the rest of sda partitions.
  3. grub-install --recheck reported no errors on /dev/sda and sdc. On sdb reported a FlexNet at sector 32. I applied the fix per this guide
  4. I backed up and deleted the first 63 sectors of sda and sdb with sudo dd and did a grub-install and grub-update on sda. Also did a grub-install --recheck on sdb and sdc just in case.
  5. The instructions in these guides didn't work and the boot is corrupted in several ways:

a.- As mentioned SSD gets detected randomly by the BIOS.

b.- If I set the SSD as the default boot drive it enters the GRUB rescue mode.

c.- If I boot the SSD with the boot override option of the BIOS it enters Manjaro GRUB just fine.

d.- Selecting either Manjaro or Windows 10 boot reports a boot error that the system is trying to read/write outside the physical drive with this log reported only booting Manjaro:

Read/Write outside drive error log

Logs and info related to this situation:

I think it may be related with the hybrid BIOS option of this card. Before this bug I couldn't boot my Manjaro liveUSB in UEFI mode (seems an EFI compatibility problem related to my ASUS Mobo)

But after this error the liveUSB defaulted to a successful UEFI boot after BIOS post.

Also at boot the liveUSB reported a lot of read/write errors of the SSD and took a very long time to boot Manjaro XFCE.

After that boot the next ones reported much less errors and booted in much less time. Here's a pastebin link to journalctl -b log of the liveUSB. (This is the only log I can include since I can't boot to my base Manjaro system)

This error in the pastebin log:

nov 25 19:40:37 manjaro kernel: ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20170728/psargs-364)
nov 25 19:40:37 manjaro kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.SAT0.SPT1._GTF, AE_NOT_FOUND (20170728/psparse-550)

Appeared since I installed Manjaro (so not related with the present bug) and is easily solvable by adding:

sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="libata.noacpi=1"
sudo update-grub
  • 2
    The fact that errors are occuring in the bios leads me to believe, that the issue is the card itself. As the BIOS is indepentent of the main OS. I would check the slot the card is in and the contacts or lands on the card that go into the slot. Also how old is the SSD? – Michael Prokopec Nov 25 '18 at 20:23
  • Thanks for your answer Michael. Indeed is a very strange issue, the BIOS resolution was perfect before letting Manjaro install the video-linux drivers.After that it broke the resolution but plugging a spare videocard and replugging the new card solved the bad BIOS resolution problem. The SSD is from 2014. – ManjaroDan Nov 25 '18 at 20:27
  • So the BIOS issue was the cleanliness of the connection. As for the rest of the problem though. Hmm... Is the BIOS upto date? – Michael Prokopec Nov 25 '18 at 20:32
  • I suspect you are dealing with several unrelated issues and the SSD might be dying. – Rui F Ribeiro Nov 25 '18 at 20:35
  • @RuiFRibeiro I agree – Michael Prokopec Nov 25 '18 at 20:36
0

As Michael Prokopec suggested plugging the SSD in another system and cleaning contacts solved the problem.

At boot the other system did an e2fsck on the SSD reporting it healthy as well. Afterwards I tried to reproduce the error and seems it's working for now.

It may be a defective mobo (I suspect a socket pins problem) or the SATA contacts as Michael mentions. This is because booting a Manjaro liveUSB in the affected system semi-successfully tried to do an e2fsck at boot. Only booting in another motherboard with a Manjaro system fixed it.

NOTE: the corrupted BIOS screen was caused by a dual monitor/TV setup. As soon as I turned on the PC without the TV plugged in the HDMI port the BIOS screen went back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.