0

I do have machines or VMs that do not have a floppy drive and I want to avoid getting the below error message while loading the the anaconda kickstart installer on CentOS/Fedora.

Currently the first message appearing after kernel is loaded is

dracut-pre-udev[333]: modprobe: ERROR: could not insert 'floppy': No such device

I even added the modprobe.blacklist=floppy to the kernel options (append) without any success.

Is there something I can do to avoid this failure? ... other than adding a floppy to the machine. The error is not fatal but I suspect it adds an extra delay at boot time which I would prefer to avoid.

  • 3
    I cut the floppy from my vmware VM master template on the hypervisor/vcenter side. Usually the error only appeared when it was there. Nevertheless, the modprobe blacklisting is not enough, you need to regenerate the initrd – Rui F Ribeiro Nov 25 '18 at 17:11
  • Does your kernel options really applied? Can you show content of /proc/cmdline? – IvanBayan Nov 26 '18 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.