0

on my RedHat 7, i noticed that network connection for Netbackup stopped working and i tried everything including rurning off my firewall and disabled SELINUX with no luck. the only thing i noticed different between this server and other servers is that port 1556 is listening on tcp & tcp6 where the same port on other servers only listen on tcp and not tcp6. Could that be causing the connection to stop? Is there a way to force port 1556 to listen ONLY on tcp and not tcp6? here's what i see when i run netstat on port 1556

[root@server ~]# netstat -tupln | grep 1556
tcp        0      0 0.0.0.0:1556            0.0.0.0:*               LISTEN      2498/pbx_exchange
tcp6       0      0 :::1556                 :::*                    LISTEN      2498/pbx_exchange
  • Any answer folks?? – Katkota Nov 28 '18 at 2:32
1

It's hard to say exactly what's causing the error.

Having IPv6 enabled, and listening on the same port shouldn't cause issues.

Any system which has dual-stack capability should handle it fine.

I've found this bug report from Veritas (and I'm making an assumption that you're using what they refer to as Netbackup) but I have no idea if this could be the issue you're facing. I will admit upfront that I do not have experience with Netbackup.

So I can only really answer the "is this what's causing the issue" part of the question.

As for the "can you force it to listen only on IPv4", you probably can, and it should be somewhere in the configuration for Netbackup pertaining to what port/IP addresses it's listening on. If it is listening on ALL available IP addresses for the server, and the server has dual-stack IPv4 and IPv6, it will listen for connections from both. So if you can bind Netbackup to an IPv4 address allocated to your server, that should disable the IPv6 functionality.

0

Thanks.. I updated the kernel and somehow the issue went away and you were correct, IPv6 wasn't the issue since the port still listening on IPv6 but now i have connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.