0

I'm facing font issue after updating Firefox ESR to latest Firefox on Debian Stretch.

Following top voted comment on this Reddit question I set up unstable repository, removed firefox-esr and installed firefox package with apt. While firefox was installing, I got a popup from apt, saying the following:

fontconfig (2.12.3-0.2) unstable; urgency=medium

Starting with version 2.12, fontconfig is using "Slight" (hintslight) as
automatic hinting style. This might change the rendering of the fonts.

If you want the to restore the old hinting, run "dpkg-reconfigure
fontconfig-config" and select "Full" as hinting style.

-- Laurent Bigonville <[…]>  Tue, 04 Jul 2017 21:10:57 +0200

The installation followed and after it finished fonts in my terminal broke immediately, some letters were overlapping others, font was thinner. So I followed the message and run sudo dpkg-reconfigure fontconfig-config. Now my terminal fonts are fine, but example page I see in Firefox (63.0.1-1) is below:

broken fonts

Everything else (including Firefox's menu/settings fonts etc) in the system displays correctly. How can I fix this? I tried to run sudo apt-get install -t stable fontconfig-config=2.11.0-6.7 to downgrade fontconfig/libfontconfig1 to previous version, but apt showed me that it will remove 592 MB disk space, including system-related stuff (list here).

How can I fix all that? Ideally having Firefox 63 and good fonts everywhere, if not possible then revert to old Firefox ESR setup.

  • 1
    Somebody cares to explain the downvote? – adamczi Nov 25 '18 at 1:17
0

I solved the problem by checking fonts in Firefox's devtools:

  • first of all, after a bit of searching the net I read that Helvetica font is of raster type. Indeed it was broken Helvetica displaying on websites. The last step of running sudo dpkg-reconfigure fontconfig-config was whether to enable bitmap rendered fonts or not - here I had to switch to "No"
  • then websites displayed another font - the default for Firefox "DejaVu Sans" and "DejaVu Sans Mono". To fix it, I had to install ttf-dejavu and ttf-liberation - those two font names I got because I checked "good Firefox's" console on another workstation

After applying both above steps, it works again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.