1

I am using Terminator in Ubuntu as well as vim.

My question is whether there is a possibility to use an underscore cursor in insert mode and a block cursor in normal mode.

I read on http://vim.wikia.com/wiki/Configuring_the_cursor, that the stable version of Terminator does not support cursor shape escape codes.

Is there any way to still accomplish this using Terminator or is the only possibility using the nightly version of Terminator?

5
  • That article is outdated. You most likely already have Terminator 1.90 or newer by now which supports changing the cursor.
    – egmont
    Nov 24, 2018 at 19:20
  • Well, I've tried a lot. Could you propose an answer on how to make it happen? Currently, it shows the same cursor in the insert as well as normal mode.
    – dvg
    Nov 24, 2018 at 19:24
  • So, is your Terminator new enough? I know that Terminator supports this feature, but I don't know how to configure Vim. There are many more articles out there about this, not just the one you linked, take a look at them.
    – egmont
    Nov 24, 2018 at 19:56
  • First, to double check Terminator, you might want to try these: echo -ne '\e[1 q' and echo -ne '\e[3 q'
    – egmont
    Nov 24, 2018 at 19:59
  • Ok, thanks for your suggestions. Updated terminator and changed a bit my .vimrc file and now it works. Will post my answer here.
    – dvg
    Nov 25, 2018 at 6:50

1 Answer 1

2

Solved the issue by:

  1. Updating Terminator to 1.91:

Here is how: https://askubuntu.com/a/1065672/878005
NOTE: The install/update suggestions on the terminator site did not work for me.

  1. Update your ~.vimrc:

Here is what to add: https://stackoverflow.com/a/42118416/7507544

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.