I use arch linux and after an update about a month ago I can't boot the system anymore.

The logs show a kernel panic caused by calling /usr/bin/switch_root with arg -d.

I've tried a live cd boot and chroot into the system, followed by another update, but no luck. Also tried renaming the initramfs-fallback.img (name probably not correct, I don't recall it perfectly) to initramfs.img. I read somewhere that this could be caused by the ram disk.

whatever is calling switch_root seems to run after arch prints out the lines :: Mounting '/dev/sdc4' on real root :: Running cleanup hook [udev]

What do you think?

Kernel panic picture: enter image description here

closed as unclear what you're asking by jasonwryan, RalfFriedl, Thomas, JigglyNaga, Rui F Ribeiro Dec 3 '18 at 17:08

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • The release notes for util-linux show no changes to switch_root for the last two releases, and there have been no Arch patches. Paste the full journal from a failed boot. – jasonwryan Nov 25 '18 at 2:20
  • @jasonwryan I think it's this man: git.kernel.org/pub/scm/utils/util-linux/util-linux.git/commit/… – Thomazella Nov 26 '18 at 1:37
  • That would seem unlikely: this would be an issue affecting a lot more people. Please paste the actual journal. – jasonwryan Nov 26 '18 at 1:47
  • @jasonwryan could you advise on pasting the journal, please? I booted to the live system, did a chroot into the old one, and read the output of journalctl, the last entries. It didn't look abnormal. Is that output what you want me to paste? I took a picture of the kernel panic at least. – Thomazella Nov 26 '18 at 2:52
  • 1
    Paste the text, not a screenshot wiki.archlinux.org/index.php/… – jasonwryan Nov 26 '18 at 3:02

I solved it by chrooting into the unbootable system and running pacman -Suy with /boot mounted correctly. Linux was updated and mkinitcpio was run automatically. My /boot is in another partition and the first time I did pacman -Suy, I didn't mount it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.