-1

My issue is:

Failed (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by plugins)

I have installed g++ (GCC) 4.9.1 20140922 (Red Hat 4.9.1-10) and centos version 6.10 (64 bit)

  • What generated that message? – Jeff Schaller Nov 24 '18 at 0:08
  • @JeffSchaller it was generated when I try to run an application but one of the plugin on that application need this. – Mart Flurry Nov 24 '18 at 0:12
  • i have also insalled gcc and g++ of version 4.9.1 using devtoolset-3 – Mart Flurry Nov 24 '18 at 0:16
1

This means you downloaded an RPM or pre-compiled binary that is using a newer version of the main C/C++ libraries on your machine. These cannot be changed. You need to (a) find an RPM version specifically built for your version of CentOS (or earlier), (b) recompile the source code or RPMs on your machine, or (c) use a container (like Docker/Moby) and run it inside an image that has the newer libraries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.