-1

I'm trying to install specific version ( 2.2.1-8+deb9u2 ) of CUPS package in debian:stretch-slim linux. But it is giving me the following error.

$apt install -y cups=2.2.1-8+deb9u2
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cups : Depends: libcups2 (= 2.2.1-8+deb9u2) but 1.7.5-11+deb8u4 is to be installed
        Depends: libstdc++6 (>= 5) but 4.9.2-10+deb8u1 is to be installed
        Depends: cups-core-drivers (>= 2.2.1-8+deb9u2) but 1.7.5-11+deb8u4 is to be installed
        Depends: cups-daemon (>= 2.2.1-8+deb9u2) but 1.7.5-11+deb8u4 is to be installed
        Depends: cups-common (>= 2.2.1-8+deb9u2) but 1.7.5-11+deb8u4 is to be installed
        Depends: cups-server-common (>= 2.2.1-8+deb9u2) but 1.7.5-11+deb8u4 is to be installed
        Depends: cups-client (>= 2.2.1-8+deb9u2) but 1.7.5-11+deb8u4 is to be installed
        Recommends: avahi-daemon but it is not going to be installed
        Recommends: colord but it is not going to be installed
        Recommends: printer-driver-gutenprint but it is not going to be installed
Unable to correct problems, you have held broken packages.
The command 'apt install -y cups=2.2.1-8+deb9u2' returned a non-zero code: 100
Build step 'Execute shell' marked build as failure
Finished: FAILURE

Where am I getting wrong?

Why is it installing 1.7.5-11+deb8u4 is to be installed?

Am I missing something here?

$ apt-cache policy cups
cups:
  Installed: 1.7.5-11+deb8u4
  Candidate: 1.7.5-11+deb8u4
  Version table:
     2.2.1-8+deb9u2 0
        -10 http://deb.debian.org/debian/ stretch/main amd64 Packages
     2.2.1-8+deb9u1~bpo8+1 0
        100 http://deb.debian.org/debian/ jessie-backports/main amd64 Packages
*** 1.7.5-11+deb8u4 0
        500 http://security.debian.org/debian-security/ jessie/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.7.5-11+deb8u2 0
        500 http://deb.debian.org/debian/ jessie/main amd64 Packages

Why am I not able to install 2.2.1-8deb9u2 version in Debian 8?

  • Looked into it further. I don't have the answer. – Michael Prokopec Nov 23 '18 at 19:01
  • You have Jessie packages rather than Stretch packages. What’s the output of apt-cache policy? – Stephen Kitt Nov 23 '18 at 19:09
  • I'll approve the pending update to your post, but you should register & use the initial account that you created to post this question. – Jeff Schaller Nov 25 '18 at 15:27
0

Because of apt pinning. Try:

apt install -t stable cups
0

Finally installed the required package version. All these days I was trying to install 2.2.1 on Debian 8 where as Debian 8 supports only till 1.7.5 .

I used Debian 9 now and it worked perfectly fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.