1

I possess an external USB 3.0 hard drive which is connected to my notebook. Of course, I do not want to just tug the connector off when I'm done; rather, I want it to safely spin down as per good practice. The one and only way I found to do this is udisksctl. Now here's the issue.

The issue

There was a time when udisksctl was working just fine. I'd enter udisksctl power-off -b /dev/<myDev>. But eventually -- I assume after an update -- everything changed. Now, whenever I enter the above command, the drive does still power-off safely, but it has the nasty side-effect of making the screen freeze. As a result, I am unable to interact with my computer in any way. The only thing I can do is to do a hard reset (i.e., slowly kill it by holding down the power button till the power is off)

I have more than enough reason to assume this is bad for the notebook. At least it clearly causes it to have trouble even booting up to BIOS in some cases, requiring multiple attempts to even start it again after such a hard power off happened. It has also caused my GRUB installation to become corrupted multiple times now.

Workaround attempts

So far, I've tried a few things to work around this issue. For instance, I tried specifying a specific partition like so, hoping it'd make a difference: udisksctl power-off -b /dev/sdb1. No success.

I also attempted running the same command as root (i.e. sudo udisksctl power-off -b /dev/sdb). No success.

Finally, I also tried running the command not in a terminal in a graphical environment, but on another tty. So I switched to say tty2 to run the same command. Once again, no success. Though at least I was met with some error messages which I presume to be on the kernel level. Unfortunately, I was unable to capture them in a photo, as new errors had pushed it off the screen before I could make the shot.

Question

Does anybody else know of or has experienced this particular issue recently? As I said, it used to work fine, but eventually turned to this problematic behavior. I assume it's been almost a month by now since I first encountered the issue.

Does anybody know an alternative to udisksctl which I could try to use?

  • unmounting should be enough, modern drives will auto park the heads, so can cope with you unplugging them. – ctrl-alt-delor Nov 23 '18 at 14:56
  • Welcome to U&L! Your kernel version? – fra-san Nov 23 '18 at 18:18
  • My kernel version should be 4.9.1. 64 bit, Debian stable. – R. Hahnemann Nov 25 '18 at 0:06
  • I'm unable to find references to your exact case (I experienced this, quite similar but definitely not the same, since was with kernel 4.16). I would suggest to just upgrade your kernel (or even downgrade, if no upgrade is available), and refer to your distribution's bug tracking system. – fra-san Nov 25 '18 at 10:01
0

Aside, acknowledging the umount comment by ctrl-alt-delor: Posting photos of screens is not too well received. When dealing with virtual consoles in linux, do you know about the screendump command?

NAME

   screendump - dump the contents of a virtual console to stdout
  • Of course, a proper txt file would be most preferrable for such things. Unfortunately, as I said, I am unable to interact with the computer after issuing the command. It might be worth a try to redirect it into a txt file to see if it does actually write the error into my file system. But honestly, since it's broken my bootloader again, and this time with a much more difficult recovery procedure than usual, I'd like to avoid issuing the command again. – R. Hahnemann Nov 24 '18 at 22:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.