2

I'm encountering these errors when trying to compile a new kernel under Gentoo...

scripts/kconfig/conf  --syncconfig Kconfig
  DESCEND  objtool
  CC      kernel/bounds.s
  CC      arch/x86/kernel/asm-offsets.s
  GEN     scripts/gdb/linux/constants.py
  CALL    scripts/checksyscalls.sh
  CC [M]  arch/x86/kvm/../../../virt/kvm/kvm_main.o
  CC      init/main.o
  CC      kernel/bpf/core.o
  CC      arch/x86/ia32/sys_ia32.o
  CC      arch/x86/kernel/acpi/boot.o
  CC      arch/x86/events/amd/core.o
  CC      certs/system_keyring.o
  CC      arch/x86/entry/vdso/vma.o
  CC      arch/x86/crypto/sha1-mb/sha1_mb.o
objdump: certs/.tmp_system_keyring.o: unable to initialize decompress status for section .debug_info
objdump: certs/.tmp_system_keyring.o: unable to initialize decompress status for section .debug_info
objdump: certs/.tmp_system_keyring.o: file format not recognized
  EXTRACT_CERTS
  AS      certs/system_certificates.o
  AR      certs/built-in.a
objdump: arch/x86/ia32/.tmp_sys_ia32.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/ia32/.tmp_sys_ia32.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/ia32/.tmp_sys_ia32.o: file format not recognized
objdump: arch/x86/events/amd/.tmp_core.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/events/amd/.tmp_core.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/events/amd/.tmp_core.o: file format not recognized
  CC      arch/x86/ia32/ia32_signal.o
  CC      arch/x86/mm/init.o
  CC      arch/x86/events/amd/uncore.o
objdump: arch/x86/entry/vdso/.tmp_vma.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/entry/vdso/.tmp_vma.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/entry/vdso/.tmp_vma.o: file format not recognized
  CC      arch/x86/entry/vdso/vdso32-setup.o
objdump: arch/x86/kernel/acpi/.tmp_boot.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/kernel/acpi/.tmp_boot.o: unable to initialize decompress status for section .debug_info
objdump: arch/x86/kernel/acpi/.tmp_boot.o: file format not recognized
  CC      arch/x86/kernel/acpi/sleep.o
  AR      arch/x86/crypto/sha1-mb/built-in.a
objdump: init/.tmp_main.o: unable to initialize decompress status for section .debug_info
objdump: init/.tmp_main.o: unable to initialize decompress status for section .debug_info
objdump: init/.tmp_main.o: file format not recognized
...

I've rebuilt binutils (which is the package from which objdump comes from), but that had no effect.

I can compile and install other packages/software without any problem, but this is preventing kernel compilation from completing.

1 Answer 1

2

According to bug 671650, elfutils-0.175 has problems with alignments.

Switching into linker ld.gold unveiled massive ammount of warnings about section alignments.

Try reverting to elfutils-0.173:

# emerge dev-libs/elfutils-0.173

And then rebuild your kernel.

sys-kernel/gentoo-sources-4.19.3 on my system builds and loads fine with elfutils-0.173.

1
  • Thanks, hadn't found that bug when searching, its done the trick and is now compiling fine.
    – slackline
    Nov 22, 2018 at 14:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .