3

In other terminal emulators you can usually control the amounts of lines you can scroll back, but it seems it's a fixed amount in Urxvt.

I thought the "saveLines" option controlled that but I tried changing it to a higher amount to no avail, the amount of lines displayed doesn't change no matter the amount.

Is there any way to increase the amount of lines I can scroll back?

  • 1
    Cannot reproduce your problem. I've started urxvt -sl 200000, then inside it I ran seq 1 200000, and I could it scroll back to 1. How did you set the 'saveLines' resource? – mosvy Nov 22 '18 at 0:30
  • 1
    fwiw, echo 'Rxvt.saveLines: 200000' | xrdb -override and urxvt -xrm 'Rxvt.saveLines: 200000 also work fine here. – mosvy Nov 22 '18 at 0:36
  • urxvt -sl 200000 actually worked out, thanks, none of your other options worked out for me though. I'll tweak my configs to always start urxvt with -sl 200000. – Vitor Nov 22 '18 at 1:16
  • I set "saveLines" as URxvt.saveLines: 20000 in .Xdefaults, much like the other options. – Vitor Nov 22 '18 at 1:19
  • 1
    don't bother about that; maybe someone else comes along who has an idea why urxvt isn't picking up that option from the xresources. I'd also try urxvt -xrm '*saveLines: 20000' – mosvy Nov 22 '18 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.