1

I'm facing a problem that I've never seen before. I want to load i3 with my new installation of Arch Linux but when I launch startx, the tty is freezing with no error. I've checked the log of xorg, I didn't see any error. message when launching startx

EDIT : There is a IMG of the output of . xinitrc when I comment exec i3 output of xinitrc

closed as unclear what you're asking by Gilles, Jeff Schaller, schily, RalfFriedl, Thomas Nov 22 '18 at 20:04

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • what does your .xinitrc say? – bgregs Nov 21 '18 at 13:59
  • If I run the script .xinitrc it say i3 cannot open display. I've never seen this on my last i3 installation. – DataHearth Nov 21 '18 at 14:02
  • what exactly is in your ~/.xinitrc? do you have "exec i3" listed somewhere in there? If you haven't copied a .xinitrc file over to your home directory, do this first: cp /etc/X11/xinit/xinitrc ~/.xinitrc – bgregs Nov 21 '18 at 14:05
  • I've copied the file and commented the line with twm xclock and xterm. Then I had exec i3. – DataHearth Nov 21 '18 at 14:08
  • 1
    If you aren't seeing anything other than the text console then the error is with the X server, not with what you put in .xinitrc. Has X worked before on this installation? Have you tried a display manager? Post the complete Xorg log file. – Gilles Nov 21 '18 at 21:58
0

The answer was a problem with the Nvidia drivers. Thanks to @bgregs for the additional help. So in order to solve it, I've uninstall the nvidia drivers then uninstall all xorg programs. After reinstall xorg and configure it for your own.

-2

The DISPLAY is not defined correctly in xorg.conf, or the user's environment, perhaps? Thus, the repeated message: Can't open display, DISPLAY is not set Not sure, but investigating that angle may help you.

  • Well I thought about it, but I've looked around for "regular" xorg.conf file and I've didn't see any lines with a display parameters. I've also looked on the x.org website, same. I'm out of ideas. – DataHearth Nov 21 '18 at 15:20
  • @DataHearth did you look at the last link I provided in the comments above? looks like some other users have experienced this same issue with bad Nvidia drivers – bgregs Nov 21 '18 at 17:47
  • DISPLAY is set automatically, and you can't know the value in advance. That error is not from the relevant part of the question anyway. – Gilles Nov 21 '18 at 21:56
  • @bgregs yes, I'll try next day and remove the Nvidia drivers. I'll update my post if it'll works. – DataHearth Nov 21 '18 at 22:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.