0

I'm using the following command to capture my screen: ffmpeg -f x11grab -video_size 1920x1080 -i :0.0+1920,0 -c:v libx264 artifact-test.mkv

The resulting video contains flickering artifacts that look a bit like portions of the background image come to the foreground for a few milliseconds: https://i.imgur.com/l9PDXD6.mp4

The video was recorded directly after a reboot with only a texteditor (Kate) running. The artifacts also occur when recording the screen without a running application but are harder to notice.

I'm using Manjaro Linux with:

  • KDE Plasma Version: 5.14.3
  • Qt Version: 5.11.2
  • KDE Frameworks Version: 5.52.0
  • Kernel Version: 4.14.81-1-MANJARO
  • OS Type: 64-bit

And the following ffmpeg installation:

ffmpeg version n4.1 Copyright (c) 2000-2018 the FFmpeg developers built with gcc 8.2.1 (GCC) 20180831 configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libdrm --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libjack --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxcb --enable-libxml2 --enable-libxvid --enable-nvdec --enable-nvenc --enable-omx --enable-shared --enable-version3 libavutil 56. 22.100 / 56. 22.100 libavcodec 58. 35.100 / 58. 35.100 libavformat 58. 20.100 / 58. 20.100 libavdevice 58. 5.100 / 58. 5.100 libavfilter 7. 40.101 / 7. 40.101 libswscale 5. 3.100 / 5. 3.100 libswresample 3. 3.100 / 3. 3.100 libpostproc 55. 3.100 / 55. 3.100

1

If you have an Nvidia GPU, try disabling the OpenGL option "Allow Flipping" it causes this, at least for me it did

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.