I have a Lenovo Thinkpad W550s that already has Windows 7 on it. I would like to install Fedora 29 Workstation alongside Windows 7, but I have run into some problems.

The hard drive was formatted with MBR (not GPT) and three partitions. Using the fdisk -l command from a Fedora 29 LiveUSB yields the following information:

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x7a8dee3d

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048   3074047   3072000   1.5G  7 HPFS/NTFS/exFAT
/dev/sda2         3074048 944916479 941842432 449.1G  7 HPFS/NTFS/exFAT
/dev/sda3       944916480 976771071  31854592  15.2G  7 HPFS/NTFS/exFAT

The motherboard has UEFI. However, Legacy BIOS is enabled, and Secure Boot is disabled.

In the Fedora 29 Workstation installer, I could shrink the /dev/sda2 partition, and use that for root, home, whatever, and delete the /dev/sda3 partition to satisfy the four partition limit with MBR. But when I try to install the OS, the installer gives an error about requiring a /boot/efi partition. Even when I try deleting /dev/sda1 (still from within the Fedora installer), formatting that and installing the EFI to /dev/sda1, the installer still won't proceed.

Is there a way to install Fedora 29 on this laptop without removing Windows 7? I need it for work, and can't do a reinstall of Windows 7.

| improve this question | | | | |
  • How are you installing? Via USB? How did you make the USB? I would use RUFUS from Windows. – FreeSoftwareServers Nov 21 '18 at 0:42
  • If not, try using DD from Linux or Rufus in DD mode NOT ISO Mode – FreeSoftwareServers Nov 21 '18 at 0:42
  • I used UNETbootin. I'll try using dd instead. – Ertain Nov 21 '18 at 19:09

One of two things are the issue:

  • You created a UEFI only Installer USB
  • Your booting in UEFI mode and need to boot in MBR/Legacy Mode.

If you can get to the CLI try this :



  • When I have a USB/ISO that is both UEFI/MBR compatible it usually shows two boot options in the BIOS/BootLoader. See if a second option shows up and try that and/or try messing with BIOS settings to force MBR/Legacy mode only.

  • I have also had it where Rufus (Windows ISO write to USB Tool) will say "Do you want to use ISO Mode (Recommended)" or "DD Mode" and I generally use ISO mode. But, I remember having where that created a UEFI only ISO and I then tried DD Mode and had a Hybrid USB which was both MBR and UEFI compatible. Try using DD to create installer USB and then check for a new boot entry.

| improve this answer | | | | |
  • How can I check to see whether the USB installer is UEFI only? – Ertain Nov 21 '18 at 19:11
  • 1
    The problem was with UNETbootin. I should have used dd at first to write the ISO to the USB drive instead of using UNETbootin. – Ertain Nov 22 '18 at 16:48
  • @Ertain I'm glad you got it sorted! My answer was a bit "vague" but seemed to point you in the right direction! I really like RUFUS for Windows to create USB from ISO, but if using Linux, maybe DD is the way to go! – FreeSoftwareServers Nov 23 '18 at 5:26

Try to shrink the partitions from a live cd, apply the changes in GParted or whatever. Then reboot to live cd again. Check the disk, fix the MBR if nessassary, then reboot to the installer and try installing. This should work if your BIOS setting are right.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.