1

Recently moved from Linux Mint 18.3 Cinnamon edition to Fedora 29 KDE edition keeping the home partition.

Problem was that I couldn't progress past the login screen, I was stuck in a login loop.

  • Unrelated update: Moving to Fedora Cinnamon edition, KDE is way too bugy. – daka Nov 21 '18 at 14:42
1

I had a similar problem like this in the past with Linux Mint, at that time I tried doing the following

rm ~/.Xauthority && rm ~/.ICEauthority

as suggested by a user on this thread which worked, unfortunately, it did not work this time. Which I understand because its a completely different OS.

Feel free to try it though, it could work for you.

Instead, what did work for me, was the following:

  1. Login via tty
  2. Navigate to /
  3. Run ls -lZ /home
  4. If the output of the previous command is anything other than unconfined_u:object_r:user_home_dir_t, then following the rest of the steps should solve the login loop problem, otherwise, this solution is unlikely to work for you, sorry.
  5. Run sudo restorecon -R /home
  6. Logout of tty and try to login again the normal way

thanks to

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.