1

These don't work: sudo update-rc.d kdeconnectd disable sudo systemctl disable kdeconnectd.service

There is no script for it in /etc/init.d/ and the /usr/share/dbus-1/services/org.kde.kdeconnect.service file only has Exec=/usr/lib/x86_64-linux-gnu/libexec/kdeconnectd set

sysv-rc-conf, rcconf and bum don't list kdeconnect.

/etc/xdg/autostart/kdeconnectd.desktop looks like this:

[Desktop Entry]
Type=Application
Exec=/usr/lib/x86_64-linux-gnu/libexec/kdeconnectd
X-KDE-StartupNotify=false
X-KDE-autostart-phase=0
X-GNOME-Autostart-enabled=false
OnlyShowIn=KDE;GNOME;Unity;XFCE;
NoDisplay=true

(Kdeconnectd has port 1716 open all the time when running.) It's not just starting automatically when booting but also a while after ending the process without me opening it.

I'm running Debian 9/KDE.

  • 1
    I described it for all of us here – schweik Mar 29 '19 at 17:36
0

I was facing the same issue and after being at a loss for several minutes as to where was the setting to disable kde connect from autostarting I finally found it.

I had noticed that after unlocking the graphical component and going to the application bar and clicking the button to add a graphical component kde connect had a 1 indicating one such component was enabled. Though I had no idea how to disable it as clicking on its icon brung up the option to remove the miniature box instead.

So here's how I did it: right click the miniature box and open its settings. In the miniature box settings window scroll down to the additional component section until you reach kde connect in the list. Untick the checkbox to disable it, and apply the new settings.

Hope this helps.

| improve this answer | |
  • Where do I find the "miniature box" to click for opening the settings? – mYnDstrEAm Jun 27 at 16:56
  • I guess you mean the "system tray". It disables the component, but it is in fact still running. – André Werlang Jul 10 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.